• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Send email errors

#1
Recently my forum VPS Hosting changed and everything is perfect except for one thing constantly giving error can not send emails or change the password can be reset or send updates to people, nothing:



Code:
#0 /home/XXXXXXXXXX/public_html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /home/XXXXXXXXXX/public_html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 /home/XXXXXXXXXX/public_html/library/XenForo/Mail.php(177): Zend_Mail->send()
#3 /home/XXXXXXXXXX/public_html/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#4 /home/XXXXXXXXXX/public_html/library/XenForo/Model/UserConfirmation.php(136): XenForo_Mail->send('juanjillovera23...', 'Blastt-Modzz')
#5 /home/XXXXXXXXXX/public_html/library/XenForo/ControllerPublic/Register.php(289): XenForo_Model_UserConfirmation->sendEmailConfirmation(Array)
#6 /home/XXXXXXXXXX/public_html/library/UserEss/ControllerPublic/Register.php(68): XenForo_ControllerPublic_Register->actionRegister()
#7 /home/XXXXXXXXXX/public_html/library/Nobita/AccountDetection/XenForo/ControllerPublic/Register.php(11): UserEss_ControllerPublic_Register->actionRegister()
#8 /home/XXXXXXXXXX/public_html/library/XenForo/FrontController.php(347): Nobita_AccountDetection_XenForo_ControllerPublic_Register->actionRegister()
#9 /home/XXXXXXXXXX/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#10 /home/XXXXXXXXXX/public_html/index.php(13): XenForo_FrontController->run()
#11 {main}

array(3) {
["url"] => string(49) "http://www.moddersnationesp.net/register/register"
["_GET"] => array(0) {
}
["_POST"] => array(16) {
["username"] => string(12) "XXXXXXXXXX"
["email"] => string(25) "XXXXXXXXXX@gmail.com"
["password"] => string(8) "********"
["password_confirm"] => string(8) "********"
["dob_month"] => string(1) "1"
["dob_day"] => string(2) "03"
["dob_year"] => string(4) "1994"
["gender"] => string(4) "male"
["custom_fields"] => array(10) {
["escribe_tu_cuenta"] => string(0) ""
["Prestigio_CoD_4"] => string(0) ""
["Prestigio_CoD_5"] => string(0) ""
["Prestigio_CoD_6"] => string(0) ""
["Prestigio_CoD_7"] => string(0) ""
["Prestigio_CoD_8"] => string(0) ""
["Prestigio_CoD_9"] => string(0) ""
["skype"] => string(0) ""
["twitter"] => string(0) ""
["facebook"] => string(0) ""
}
["custom_fields_shown"] => array(10) {
[0] => string(17) "escribe_tu_cuenta"
[1] => string(15) "Prestigio_CoD_4"
[2] => string(15) "Prestigio_CoD_5"
[3] => string(15) "Prestigio_CoD_6"
[4] => string(15) "Prestigio_CoD_7"
[5] => string(15) "Prestigio_CoD_8"
[6] => string(15) "Prestigio_CoD_9"
[7] => string(5) "skype"
[8] => string(7) "twitter"
[9] => string(8) "facebook"
}
["timezone"] => string(16) "Europe/Amsterdam"
["captcha_question_answer"] => string(1) "4"
["captcha_question_hash"] => string(40) "89d9847332739e4413d04a738964937b5c5f13f1"
["agree"] => string(1) "1"
["_xfToken"] => string(8) "********"
["reg_key"] => string(32) "186c47cf137e34599baa8b626fb34958"
}
}
 

borbole

Well-known member
#2
Recently my forum VPS Hosting changed and everything is perfect except for one thing constantly giving error can not send emails or change the password can be reset or send updates to people, nothing:



Code:
#0 /home/XXXXXXXXXX/public_html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /home/XXXXXXXXXX/public_html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 /home/XXXXXXXXXX/public_html/library/XenForo/Mail.php(177): Zend_Mail->send()
#3 /home/XXXXXXXXXX/public_html/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#4 /home/XXXXXXXXXX/public_html/library/XenForo/Model/UserConfirmation.php(136): XenForo_Mail->send('juanjillovera23...', 'Blastt-Modzz')
#5 /home/XXXXXXXXXX/public_html/library/XenForo/ControllerPublic/Register.php(289): XenForo_Model_UserConfirmation->sendEmailConfirmation(Array)
#6 /home/XXXXXXXXXX/public_html/library/UserEss/ControllerPublic/Register.php(68): XenForo_ControllerPublic_Register->actionRegister()
#7 /home/XXXXXXXXXX/public_html/library/Nobita/AccountDetection/XenForo/ControllerPublic/Register.php(11): UserEss_ControllerPublic_Register->actionRegister()
#8 /home/XXXXXXXXXX/public_html/library/XenForo/FrontController.php(347): Nobita_AccountDetection_XenForo_ControllerPublic_Register->actionRegister()
#9 /home/XXXXXXXXXX/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#10 /home/XXXXXXXXXX/public_html/index.php(13): XenForo_FrontController->run()
#11 {main}

array(3) {
["url"] => string(49) "http://www.moddersnationesp.net/register/register"
["_GET"] => array(0) {
}
["_POST"] => array(16) {
["username"] => string(12) "XXXXXXXXXX"
["email"] => string(25) "XXXXXXXXXX@gmail.com"
["password"] => string(8) "********"
["password_confirm"] => string(8) "********"
["dob_month"] => string(1) "1"
["dob_day"] => string(2) "03"
["dob_year"] => string(4) "1994"
["gender"] => string(4) "male"
["custom_fields"] => array(10) {
["escribe_tu_cuenta"] => string(0) ""
["Prestigio_CoD_4"] => string(0) ""
["Prestigio_CoD_5"] => string(0) ""
["Prestigio_CoD_6"] => string(0) ""
["Prestigio_CoD_7"] => string(0) ""
["Prestigio_CoD_8"] => string(0) ""
["Prestigio_CoD_9"] => string(0) ""
["skype"] => string(0) ""
["twitter"] => string(0) ""
["facebook"] => string(0) ""
}
["custom_fields_shown"] => array(10) {
[0] => string(17) "escribe_tu_cuenta"
[1] => string(15) "Prestigio_CoD_4"
[2] => string(15) "Prestigio_CoD_5"
[3] => string(15) "Prestigio_CoD_6"
[4] => string(15) "Prestigio_CoD_7"
[5] => string(15) "Prestigio_CoD_8"
[6] => string(15) "Prestigio_CoD_9"
[7] => string(5) "skype"
[8] => string(7) "twitter"
[9] => string(8) "facebook"
}
["timezone"] => string(16) "Europe/Amsterdam"
["captcha_question_answer"] => string(1) "4"
["captcha_question_hash"] => string(40) "89d9847332739e4413d04a738964937b5c5f13f1"
["agree"] => string(1) "1"
["_xfToken"] => string(8) "********"
["reg_key"] => string(32) "186c47cf137e34599baa8b626fb34958"
}
}

A couple of add ons are mentioning at the error message. Can you try to disable them and see if the error will still occur?
 

borbole

Well-known member
#5
Thanks for your input but no, and disabled the add ons, but nothing is giving error.
Didn''t the error go away? Did you disable all add ons? In that case open a ticket at your customer area here so one of the staff can look into this for you.

Also try to contact your host so they can check things on their end as well.
 

Mike

XenForo developer
Staff member
#6
Nothing much we can do. If it started when you changed to a different VPS, it would indicate a misconfiguration on the new VPS. I would guess it doesn't actually have a mail program installed, so you should check that (if it is installed, make sure PHP is configured to use it).

As a final option, you could switch to send mail via SMTP.
 

Tracy Perry

Well-known member
#7
Recently my forum VPS Hosting changed and everything is perfect except for one thing constantly giving error can not send emails or change the password can be reset or send updates to people, nothing:
Sometimes, if you are using Debian and the default Exim4 install, the MTA is only set up for local mail delivery. You can either change the MTA to Postfix or reconfigure the Exim4 MTA by issuing the command dpkg-reconfigure exim4-config and choose the correct option to configure it for internet delivery.