• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Future fix Search threads started by this member only does not work

Amaury

Well-known member
#21
@Mike

I know this is still a future fix, but it seems the bug is more with Display results as threads than Search threads started by this member only. See my post on KH-Vids (which is running XenForo 1.2.4 right now) here from a while ago and then @mistypants' response below.

While I may be able to see all threads I've started via my profile (as you mentioned in @Stuart Wright's thread), I can't see all threads I started in, say, only XenForo Bug Reports.

Here's a short video where I use both of the search options I mentioned above. It's pretty self-explanatory, but let me know if you need any details. Watch in full screen and 1080p:


You'll notice how if I deselect Display results as threads here on XenForo, it shows only my content, but as both threads and posts and not just threads because you hid Search threads started by this member only, so I'm unable to use that.
 

Jeremy

Well-known member
#22
I think you misunderstand the goal behind "Display results as threads". It is working as designed, to say that you posted in a thread. If you look at the posts, you'll find they belong to the threads that appear.
 

Amaury

Well-known member
#23
I think you misunderstand the goal behind "Display results as threads". It is working as designed, to say that you posted in a thread. If you look at the posts, you'll find they belong to the threads that appear.
Then the wording is confusing, no? That's what Misty mentioned in the thread I linked to above.

Okay, so then, putting that aside, why was Search threads started by this member only removed? Because now I can't search for threads only I started in a certain forum here. And it will be the same once KH-Vids and KH-Flare update to XenForo 1.3.
 

AndyB

Well-known member
#24
why was Search threads started by this member only removed?
Because it was originally designed so keywords would search the title AND message. However it didn't work that way and it only searched the title, even though "Search titles only" was not checked.
 

Amaury

Well-known member
#25
Because it was originally designed so keywords would search the title AND message. However it didn't work that way and it only searched the title, even though "Search titles only" was not checked.
Yeah, but now I can't search for threads only I started in, for example, XenForo Suggestions.
 

Autonamus

Active member
#27
Unfortunately this is correct.

I hope Mike fixes this soon as I often used "Search threads started by this member only" too.
I'd have to agree, I'm shocked it's taken me as long as it has to realize it's missing.

Hopefully it makes it's return as a fixed item soon.
 

Mike

XenForo developer
Staff member
#31
Arguably, I'm not sure this particular option will ever come back, at least with what the original wording implied. (It implied that it would search any content within a thread started by a particular user, even posts not by that user.) I'm not sure how helpful that actually is.

It's worth noting that for many of the common cases, this option isn't needed. For example, we expose searching for threads started by arbitrary users already (via their profile). You can filter a forum down to threads started by a particular user too.

In XF1, it was effectively the same as just doing a title search. This is a little different in XF2 because we now index the first post content with the "thread" record instead. So I could see an option to only search the initial thread entry (and not replies), but I don't think the original option in question (which never worked as implied) would come back.