1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

safe_mode off...

Discussion in 'Installation, Upgrade, and Import Support' started by Nasr, Oct 23, 2010.

  1. Nasr

    Nasr Well-Known Member

    safe_mode is off on my webhost server but i'm getting ...

    The following errors occurred while verifying that your server can run XenForo:

    • PHP must not be running in safe_mode. Please ask your host to disable the PHP safe_mode setting.
    Please correct these errors and try again.

    I've checked phpinfo.php and safe_mode is off.

    any reason that could cause this?
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Is the phpinfo file in the same directory as the test script? It's possible to have different PHP configurations per directory on some servers.
     
    Jurhum likes this.
  3. Thorsten

    Thorsten Member

    I figured out the same problem.

    In my php.ini i set:

    Code:
    safe_mode = Off
    
    then i checked the setting by using an info.php, like:
    Code:
    <?
      phpinfo();
    ?>
    
    It results in telling me, that the safe_mode is off.
    Anyways installation canceled by telling me, that i have to switch off safe_mode.

    In my case the solution was to set in my php.ini:

    Code:
    ; safe_mode = off
    
    I think the problem is, that the Requirement-Test-Script checks if there is any safe_mode-setting (no matter if on or off) instead of checking, if safe_mode is off.
     
    Jurhum likes this.
  4. Nasr

    Nasr Well-Known Member

    Yes the phpinfo is on the same directory and it shows safe_mode as off.
     
  5. Nasr

    Nasr Well-Known Member

    I have my local server set to off and it worked without a problem. Maybe they just need to restart php again.
     
  6. Thorsten

    Thorsten Member

    This might be a problem as well. In my case i restarted apache2 and reconfigured the vhost first, of course ,)

    Perhaps the problem just appears in special cases. A similar problem may be found in phplist: http://mantis.phplist.com/view.php?id=15273
     
    Jurhum likes this.
  7. Nasr

    Nasr Well-Known Member

    Interesting to see that. I'm thinking xF has the same issue? Which file has the safe_mode check script? install.php? i'll look into it and see...
     
  8. Nasr

    Nasr Well-Known Member

    actually we were able to remove safe mode from the entire account. fixed and now importing data.
     
  9. Thorsten

    Thorsten Member

    Even if it is working for you, here the information, where:
    Code:
     if (@ini_get('safe_mode'))
                    {
                            $errors['safe_mode'] = new XenForo_Phrase('php_must_not_be_in_safe_mode');
                    }
    
    can be found.

    It is in: /library/XenForo/Install/Model/Install.php

    Greets
     
    Jurhum likes this.
  10. Kingpui

    Kingpui New Member

    Great, its work - thank you.
     

Share This Page