• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not planned php safe mode on

#1
hello
i see the one of requirements is php safe mode off
can you make it works ith php safe mode on
and why it´s required php safe mode off?

thanks
Ali
 

Martok

Well-known member
#2
This:

We require safe mode to be off, mostly due to manipulating the file system in some instances. So XF requires safe_mode to be off when running.
and

Not to mention that 'safe mode' is one of the worst naming choices in the history of the PHP language.

Also, Safe Mode is deprecated in PHP 5.3 and removed in PHP 5.4, and XenForo 2.0 requires PHP 5.4 or higher.