1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed running the importer 2x results in duplicate threads - there is no way to recover from that.

Discussion in 'Resolved Bug Reports' started by Dean, Oct 11, 2010.

  1. Dean

    Dean Well-Known Member

    Dodgeboard, steven s and Blandt like this.
  2. Blandt

    Blandt Well-Known Member

    I had to drop my xF database, reinstall then re-import
     
  3. yoghurtfarmer

    yoghurtfarmer Well-Known Member

    Did not happen to me and I've done it a ton of times both in a local environment and on the real server.

    The important thing was a reinstall (did not have to reupload files) and clearing out the old xF data.

    If you don't reinstall, you'll get duplicate. Likewise, if you run the importer and don't complete it, and then choose to discontinue and redo the import, you'll also get duplicates. However, it does warn you that it happens.

    Deleting the install-lock and reinstalling always worked for me.
     
  4. Mike

    Mike XenForo Developer Staff Member

    I have seen Chrome try to do a double import. It actually seems like at times, it can double request pages. I haven't figured out why yet.
     
    Dodgeboard likes this.
  5. Andy.N

    Andy.N Well-Known Member

    Yes, I did my import using Chrome so it's a valid data point.
     
  6. steven s

    steven s Well-Known Member

    Same issue with Firefox.
     
  7. Mike

    Mike XenForo Developer Staff Member

    I've tracked down the double request issue - stupid mistake on our part. This should be fixed for beta 2.
     
    Dean, Blandt and Andy.N like this.
  8. Andy.N

    Andy.N Well-Known Member

    Wohoo...glad it sorted out. This is why we have the bug report forum for.
     

Share This Page