1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Running a Usergroup Promotion cron job

Discussion in 'XenForo Questions and Support' started by Lone Wolf, Dec 13, 2013.

  1. Lone Wolf

    Lone Wolf Well-Known Member

    I created a new usergroup and went to Tools > Cron Entries > User Group Promotion > Run and the entry runs instantly (no delay, within a second) but no users are updated to join the new usergroup. I'm guessing it should take a lot longer than that.

    Am I doing something wrong?
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    Did you add a new user group promotion or a new user group? The cron job runs on recently active users only.
     
  3. Lone Wolf

    Lone Wolf Well-Known Member

    I added both. Is there a way to run it on all users? Perhaps with a query?
     
  4. Mike

    Mike XenForo Developer Staff Member

    There's a promotion rebuild in the rebuild caches section.
     
  5. Lone Wolf

    Lone Wolf Well-Known Member

    My main site is still on 1.1.1

    I can see the rebuild user promotions in 1.2.3 on my development site but not the main site. How do I do it in 1.1.1?
     
  6. Mike

    Mike XenForo Developer Staff Member

    You would need to modify the code of the cron (which may trigger other issues). I could really only recommend the standard method that's part of 1.2.
     
    Lone Wolf likes this.
  7. Lone Wolf

    Lone Wolf Well-Known Member

    Thanks Mike, I guess I'll wait till I have upgraded to 1.2
     

Share This Page