• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Rotate Media Right not working

jOOc

Active member
#1
Just noticed that when I tried to rotate an image to the right I get an "Unexpected Error" message. Nothing turns up in the logs. Rotate to the left works just fine.

I tested this on my local site and also on @Bob's site xenaddons.com both sites gets this error. But when I try here on xenforo.com It works just fine.
I have tried to turn of many add-ons but this does not help.
 

Chris D

XenForo developer
Staff member
#2
There's not a lot to go on, unfortunately.

If I had to guess it could be your server hitting a memory limit. Though admittedly odd it works going left, I think I've seen something similar before.

Is it a large image in dimensions? If you upload a smaller image does it work?
 

jOOc

Active member
#5
Strange, when I copy the link to rotate to the right and past it in my browser the images is rotated but also getting a border and gets blurred.
So maybe some javascript issue. Ill try some more things
 

jOOc

Active member
#9
Updated to 1.0.1 and now the rotation works but it still adds a border and blur the image

Just added image
upload_2014-12-19_10-45-39.png

After rotated to the right a couple of times (more blur each time)
upload_2014-12-19_10-46-39.png

Just noticed another very small thing, in IE11 the images are not centered on the page
upload_2014-12-19_10-47-51.png
 

Chris D

XenForo developer
Staff member
#10
There's not a lot we can do about quality issues as a result of manipulating the image. It's probably not the best example. Does it happen with larger images?

IE11 doesn't support the method we use to centre the image so that's a browser issue.
 

jOOc

Active member
#11
Yes it happens on larger images to but only when rotating to the right as I said.
The border is hard to see on this image but its to the right on the middle image
upload_2014-12-19_11-7-23.png

I tested here on your site with the small skull image and it didnt get blured or got a border rotating to the right.
Can it be a imagick issue? What version are you running here?
 

Chris D

XenForo developer
Staff member
#12
The rotate functions don't actually use ImageMagick. It should be just using PHP's built in GD support.

But, certainly, this is something server related rather than code, unfortunately.
 

jOOc

Active member
#15
And you get the same issue, rotate it a bit more times to the right and the image will be very blurred.
I created a ticket on you site.
 

MattW

Well-known member
#18
OK, so this is REALLY strange. GD and imagemagick are only reducing the quality of the image when rotating Right. Left doesn't make a difference. As soon as you start rotating right, the quality is reduced each rotation.