1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Resource Manager limitations?

Discussion in 'Troubleshooting and Problems' started by Kassierer, Jan 4, 2015.

  1. Kassierer

    Kassierer Member


    I bought the resource manager today to be able to provide downloads for the members of our church (primarily mp3 files of the latest sermons).

    After installation and changing of the settings (I changed the maximum size of resource files to 100 MB, and added mp3 as file type), I tried to create the first resource, but it failed as XenForo failed to identify the file.

    I asked in the German XenD-A-CH community and got some helpful hints. So I tried e.g. a small jpg file, that worked. A small zip file (3 MB) worked as well. So I zipped the sermon (resulted in a 11 MB zip file) and tried the resource creation again. After selecting the file, in the top right hand corner appears a moving indicator for a few seconds, and that's it - the caption of the button does not change.

    Is this a known issue? What can I do to upload a normal mp3 file? (Most of our members aren't familiar with archive formats, so the download should be in mp3 format).

    Thanks for your help!

    P.S.: XenForo is 1.4.3, Resource Manager is 1.1.5
  2. Mr. Goodie2Shoes

    Mr. Goodie2Shoes Well-Known Member

    Check you server's file upload limit.
  3. Kassierer

    Kassierer Member

    Hallo, Mr. Goodie2Shoes -

    just tried to upload the unzipped mp3 file (which is 17 MB), and it worked fine without a problem, so I assume it's not the size.

    As I understand, XenForo loads the file, checks if it really is the announced type, and will change the caption when the file is fine.

    It is a good possibility that I do something wrong, so I would love to understand what it is and how to do it correctly.
  4. Mike

    Mike XenForo Developer Staff Member

    XenForo doesn't do anything to non-image type uploads. An 11 MB zip and a 17 MB MP3 are the same to XF (aside from size).

    Your last message seemed to imply that the unzipped file worked without an issue though, so I'm not clear what the problem is specifically?
  5. Kassierer

    Kassierer Member


    sorry that it took so long to come back to this topic.

    It was a server-side problem. After contacting the server admin, he adjusted the size of an uploadable file, and after that it works fine.

Share This Page