1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Registration new user behaviour

Discussion in 'Troubleshooting and Problems' started by Cees50, Feb 15, 2014.

  1. Cees50

    Cees50 Active Member

    Hi,

    I have set the registration for new members on e-mail conformation. Its working fine, but now i have four weird problems. 4 users didnt receive an email, but when i looked in the admin panel i saw that they suddenly has to approved by an moderator?????? I take a look on the user registration setting, but they have the email conformation on and the approval out. ... I dont have any errors or something else.

    This problem is since i have 1.2.4
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Let's define the normal behavior. There are two relevant settings:

    Admin CP -> Home -> Options -> User Registration
    > Enable Email Confirmation
    > Enable Manual Approval


    Email confirmation comes first, then manual approval, after which the user is fully registered (valid state). If both options are enabled then that is the order.

    You said you have moderation disabled yet some users are being moderated. This might be due to your spam settings which can conditionally impose moderation on new accounts:

    Admin CP -> Home -> Options -> User Registration -> Stop Forum Spam
     
  3. Cees50

    Cees50 Active Member

    Thanks Jake,

    Thats it... :rolleyes:
     

Share This Page