Fixed Redactor cursor position problem

Affected version
xenforo 2.02

realaqu

Active member
#1
Hi, fellows
I found the redactor editor cursor can not stop at the right position when using Chinese pinyin input method, no such problem on xenforo1.5, please fix it

0F1E817F-22CA-40F3-B012-87B464D1C451.jpeg
 

Chris D

XenForo developer
Staff member
#2
We no longer use Redactor, and we use an editor called Froala now.

Could you please attempt to reproduce the issue on this page:

https://www.froala.com/wysiwyg-editor/

We're also going to need very specific instructions on how to trigger it. I think I just repro'd it on our forum here, but after that it seemed to be ok.

Ideally, if you can provide the exact settings you're using on your phone, and list the exact keys that need to be pressed to trigger the issue, that will help us more consistently test it in future.
 

realaqu

Active member
#3
We no longer use Redactor, and we use an editor called Froala now.

Could you please attempt to reproduce the issue on this page:

https://www.froala.com/wysiwyg-editor/

We're also going to need very specific instructions on how to trigger it. I think I just repro'd it on our forum here, but after that it seemed to be ok.

Ideally, if you can provide the exact settings you're using on your phone, and list the exact keys that need to be pressed to trigger the issue, that will help us more consistently test it in future.
Hi, Chris
here is my iphone recording, I switched to Chinese pinyin input, first two characters are correct, then more letters, backspace, look at the cursor position
 

realaqu

Active member
#4
We no longer use Redactor, and we use an editor called Froala now.

Could you please attempt to reproduce the issue on this page:

https://www.froala.com/wysiwyg-editor/

We're also going to need very specific instructions on how to trigger it. I think I just repro'd it on our forum here, but after that it seemed to be ok.

Ideally, if you can provide the exact settings you're using on your phone, and list the exact keys that need to be pressed to trigger the issue, that will help us more consistently test it in future.
no problem on froala.com
 

Chris D

XenForo developer
Staff member
#5
It's interesting that there's no problem on Froala.com. We're running a updated version here now too. Are you able to reproduce the issue on this forum anymore?

If you can, let us know the steps that triggered it. If not, then I think this might have been fixed in the latest Froala release.
 

realaqu

Active member
#6
It's interesting that there's no problem on Froala.com. We're running a updated version here now too. Are you able to reproduce the issue on this forum anymore?

If you can, let us know the steps that triggered it. If not, then I think this might have been fixed in the latest Froala release.
no problem right now, seems working fine, probably a sbc dbc issue
 

Chris D

XenForo developer
Staff member
#7
I do believe this was fixed in Froala 2.7.6 then but let us know if you notice it after upgrading to XF 2.0.3 (which should be released this week).
 
Top