• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 ReCAPTCHA (No CAPTCHA) connection error: Unable to Connect to ssl

#1
ReCaptcha works well but im taking these errors too frequently:


Connection timed out error happens in that link:
https://www.uniocraft.com/register/register
php_network_getaddresses: getaddrinfo failed: Name or service is not known error happens in that link:
"https://www.uniocraft.com/account-confirmation/resend"

Im using a dedicated server Centos 7. Do i need to configure something?
How can i handle that problem?

EDIT: I checked every other related threads and did something to fix. Nothing solved.
Here what i did:
 
Last edited:

Tracy Perry

Well-known member
#2
It looks more like a DNS resolution error... in your /etc/resolv.conf what NS servers are you using?
This is what I have, and I've never had those issues
Code:
[17:43][root@whiskey.redneckhost.com etc]# cat resolv.conf
nameserver 127.0.0.1
nameserver 8.8.8.8
nameserver 8.8.4.4
nameserver 213.186.33.99
search ovh.net
Note, I am using OVH for my dedicated server. The last two entries are specific to it and I mainly use the Google nameservers for DNS resolution.
 
#3
It looks more like a DNS resolution error... in your /etc/resolv.conf what NS servers are you using?
This is what I have, and I've never had those issues
Code:
[17:43][root@whiskey.redneckhost.com etc]# cat resolv.conf
nameserver 127.0.0.1
nameserver 8.8.8.8
nameserver 8.8.4.4
nameserver 213.186.33.99
search ovh.net
Note, I am using OVH for my dedicated server. The last two entries are specific to it and I mainly use the Google nameservers for DNS resolution.
Thanks, i set Google DNS. Lets see it will continue or not.
 

Tracy Perry

Well-known member
#5
Who is your hosting provider. Are they having any network issues... I noticed that you are also getting time-out errors. Sounds like they may have issues with their connectivity - either at your server level or within their building.
 
#6
Im running an OVH dedicated server. Actually i might have a network issues. But it is not happens everytime.

@Tracy Perry if you dont mind can you share your iptables config? Maybe the problem is related to it.
 
Last edited:
#8
I added these settings:
iptables -A INPUT -p tcp --dport 80 -j ACCEPT
iptables -A INPUT -p tcp --dport 443 -j ACCEPT
iptables -A INPUT -p tcp --dport 110 -j ACCEPT
iptables -A INPUT -p tcp --dport 143 -j ACCEPT
iptables -A INPUT -p tcp --dport 993 -j ACCEPT
iptables -A INPUT -p tcp --dport 995 -j ACCEPT
iptables -A INPUT -p tcp --dport 25 -j ACCEPT
iptables -A INPUT -p tcp --dport 587 -j ACCEPT
iptables -A INPUT -p tcp --dport 465 -j ACCEPT

After this im getting error more rare now. But still im getting.

Also error is changed. Now it is:
Zend_Http_Client_Adapter_Exception: ReCAPTCHA (No CAPTCHA) connection error: Unable to Connect to ssl://www.google.com:443. Error #0: php_network_getaddresses: getaddrinfo failed: Name or service not known - library/Zend/Http/Client/Adapter/Socket.php:235