1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot Reproduce Quick reply crashes when qouting, especially quoted links

Discussion in 'Resolved Bug Reports' started by Dean, Aug 8, 2010.

  1. Dean

    Dean Well-Known Member

    When I quote someone and type under the quote a few sentences, then for some reason I click in the quoted area (such as attempting to type above the quoted post) everything I've typed below the quote disappears and cannot be recovered. The Fire fox "undo" command does nothing.

    It is especially problematic when quoting a post with a link in it.

    I think this could be a bug. It is bad enough that I rarely use the quick reply when typing something I care about.
  2. Floris

    Floris Guest

    Can't reproduce this, tried 5 browsers on 2 operating systems.
  3. Dean

    Dean Well-Known Member

    testing... that time it worked.
    All within 1 minute? You are FAST!

    edit: here is a link

    random text below it.
  4. KURTZ

    KURTZ Well-Known Member

  5. Dean

    Dean Well-Known Member

    Special request for the staff. Could you give me a day to dig into this, if need be, and not mark the thread 'not a bug' or close it?

    I think there really is an issue but cannot replicate the exact situation.
  6. Dismal Shadow

    Dismal Shadow Active Member

    I got this crash earlier today, can't remember how to reproduce it but it's related to quoting/preview in advance editor.

    On Chrome 5 Mac OSX
  7. KURTZ

    KURTZ Well-Known Member

    i noticed this w/FF 3.6.8
  8. Dean

    Dean Well-Known Member

    This has been happening about 20% of the time today. I cannot see any pattern.

    I thought it was due to quoting links, or even using right click fix spelling in FF, but cannot see a pattern. It make the quick reply for anything more than a few words not really suitable. The 'More Options' method of making a post has worked 100% of the time.

    Fire fox 3.6.3 on a PC.
  9. Kier

    Kier XenForo Developer Staff Member

    There are relatively rapid changes going on in the javascript here - it should be stable for the rest of the night, so could you try clearing your cache for XenForo.com and ensuring that you have the very latest javascript files, just in case that's the issue? Thanks.
  10. Dean

    Dean Well-Known Member

    I can tell :p

    I know how to clear the cache, and have done so. How to ensure I've got the latest javascript files?
  11. Kier

    Kier XenForo Developer Staff Member

    A hard refresh should be all that's required.
  12. Dean

    Dean Well-Known Member

    Hard refresh complete.

    I will test in the proper test forum.
  13. Dean

    Dean Well-Known Member

    Exactly 10 minutes ago it happened again. It was the first time since my previous post.

    I also now notice what might be some changes, i.e. being able to manage multiple subscribed threads now, that might be new.
  14. Mike

    Mike XenForo Developer Staff Member

    Can you still reproduce this? I fixed another bug involving QR that changes the structure of the HTML that's inserted, so it's very likely that this won't occur any more.
  15. Dean

    Dean Well-Known Member

    It just happened 2 more times in the last 90 minutes. I will clear my cache and do a hard refresh and let you know if/when it happens again.

    The problem manifests itself almost always when I am deleting part of someones quote that I want to specifically refer to. At first I thought it only happened when links were quoted, or even smilies, but I believe it happens with simple text as well.
  16. KURTZ

    KURTZ Well-Known Member

  17. Dean

    Dean Well-Known Member

Share This Page