• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Quick Navigation for Forums Tab

#1
Is there anyway to get Quick Navigation to show up in the Forums tab? Similar to what vB has with most of it's Forum tabs... it shows all the forums to easily navigate to any particular forum.

Thanks!
 

Brogan

XenForo moderator
Staff member
#2
You can edit the navigation template to add a new link.
Code:
<a href="{xen:link misc/quick-navigation-menu, '', 'selected={$quickNavSelected}'}" class="OverlayTrigger jumpMenuTrigger" data-cacheOverlay="true" title="{xen:phrase open_quick_navigation}"><!--{xen:phrase jump_to}...--></a>
 
#3
I was thinking more along the lines of when I hover the Forums tab it would show the quick navigation menu, which has all of the forums listed. As it stands, the Forums tab has Mark Forums Read, New Posts, Search Forums, Watched Forums, etc., which really are not considered Forums. They are more akin to Tools, or could be considered Quick Links. When I see a Forums tab... I would think hovering it would show me forums, as the tab would indicate... and like I see on nearly every forum site I visit... other than here.
 
#4
Actually... if I can figure out how to add just the Forum List part of the Quick Navigation to the bottom of the Forums tab... that would be a respectable solution.
 
#5
Is this UI.X or is it XF? It is so redundant and dysfunctional. It's the same thing. You hover the FORUMS tab and it shows the same links that are already showing. Does it not make sense to others that when you hover the FORUMS tab you should see a list of forums instead of a list of tools that are already listed? What am I missing?

upload_2017-3-14_19-15-49.png
 

Attachments

Optic

Well-known member
#6
Your screenshot shows you are on a custom page so the navigation looks like its working correctly?

The pop-up menu definitely shouldn't appear once you're on the Forumst ab..
 
#7
It's the same thing when in the forums. The HOME tab dropdown menu shows the same links already showing. It may be working correctly, but it makes zero sense to show links in a drop down menu when you already have links showing up in the same general area that do not require a drop down. It is extremely redundant.
 
#8
You can edit the navigation template to add a new link.
Code:
<a href="{xen:link misc/quick-navigation-menu, '', 'selected={$quickNavSelected}'}" class="OverlayTrigger jumpMenuTrigger" data-cacheOverlay="true" title="{xen:phrase open_quick_navigation}"><!--{xen:phrase jump_to}...--></a>
That link does not work. The requested page could not be found.