1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed proxy.php?image failing

Discussion in 'Resolved Bug Reports' started by MattW, Jan 28, 2014.

  1. MattW

    MattW Well-Known Member

    I've added my own images to a resource, and the images are failing to load due to the proxy running

    The URL being generated :
    Correct image URL
    The were inserted into the resource using the IMG tags


  2. Mike

    Mike XenForo Developer Staff Member

    It looks like the early "is image" check that we're doing was failing. I've tweaked this check to happen a bit later, though it could just be disabled entirely if needed (it just breaks early if an invalid image is given).
  3. Moshe1010

    Moshe1010 Well-Known Member

    I'm not sure if it's connected, but I've tried to post an image here:

    This one:

    And it does the same thing.
  4. Mike

    Mike XenForo Developer Staff Member

    That appears to be from the "Image Cache Max Size (Kilobytes)" option. (It defaults to 5MB, that image is 34MB.)
  5. Moshe1010

    Moshe1010 Well-Known Member

    So just to make sure. If I set the limit to 0 and choose to cache such images for let's say 7 days, after 7 days they would be gone from my server automatically (meaning it wouldn't affect my server's disk space more than 7 days)?
  6. Mike

    Mike XenForo Developer Staff Member

    It would automatically be retrieved if it were requested again by someone viewing the thread.
    Moshe1010 likes this.
  7. Moshe1010

    Moshe1010 Well-Known Member

    Yes, thanks.
  8. HazedOff

    HazedOff Member

    @Mike my own forum is experiencing a smilar problem, how do I fix?
  9. Jeremy

    Jeremy Well-Known Member

    Are you running the latest version?
  10. HazedOff

    HazedOff Member

    1.4.5? yeah?
  11. Mike

    Mike XenForo Developer Staff Member

    Your issue is very likely unrelated. I would recommend posting a thread in troubleshooting with all the details you can provide.

Share This Page