• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Problems with SSL

#2
Are you hot linking any images from other websites? If so you should host them on your own server / hosting and also change all existing urls that are 'HTTP' to 'HTTPS'
 
#3
No i am not linking images from other website. Everything i am hosting on my server. I am using SSL from Cloudflare, with WBB 4.1 i had no problems.
 

Mike

XenForo developer
Staff member
#5
I am using SSL from Cloudflare, with WBB 4.1 i had no problems.
So CloudFlare isn't actually requesting your site via SSL? That's the problem. You need to force XF to think it's accessed via SSL by putting this in config.php:
Code:
$_SERVER['HTTPS'] = 'on';
 
#6
So CloudFlare isn't actually requesting your site via SSL? That's the problem. You need to force XF to think it's accessed via SSL by putting this in config.php:
Code:
$_SERVER['HTTPS'] = 'on';
Damn i dont have any olan in SSL, but when i force over Admin Control Panel the site is stil broken without any Style. I just use http: in ACP so my User can Login to the website. Can some1 take a look over it?

Thank you
 

Mike

XenForo developer
Staff member
#7
I'm confused because you said you're using SSL via CloudFlare, but now you're saying you're not using SSL at all.

I also loaded your site and it seemed fine at a glance so you'll need to explain specific steps to reproduce the issue.
 
#8
No, i am using SSL via ClooudFlare, but with xenforo it doesnt work. I got problems with it, my page looks from 1995.

With WBB i had there no problems. I have disabled SSL in Cloudflare now becouse this problem. It works now without SSL.

So here the steps.

1. I had WBB and i installed ago 2 Months Cloudflare without any problems.
2. Yesterdey i imported everything to MyBB
3. Then Import from MyBB to Xenforo
4. After it, i moved Xenforo to the main Folder on my Server, and WBB to a subfolder.
5. When i visit my page over HTTP:// everything is okey, but over HTTPS:// there is no Design, no images, nothing.
 
#9
On cloudflare do you have SSL Set to full? and the always use ssl rule turned on? also as mike said put this in /library/config.php
Code:
$_SERVER['HTTPS'] = 'on';
 
#10
I think you dont understand me, on Burning Board 4.1 it worked, so it must be "on ". I dont have the root PW for my server, but i contacted my Hoster.

With SSL my Xenforo looks now:

123.jpg

Happy new Year !
 

Mike

XenForo developer
Staff member
#11
You're forcing your site to HTTP right now, so we can't verify, but if you're going to force HTTPS, you need to add the line discussed to your library/config.php file.
 
#14
I have the exact same problem, I'm using a lets encrypt certificate and I already put the code in config.php, but the page loads without any image at all.

I also have the SSL option set to "full":

Captura de pantalla 2016-12-08 a la(s) 14.27.38.png

Any ideas?
 
#15
I have the exact same problem, I'm using a lets encrypt certificate and I already put the code in config.php, but the page loads without any image at all.

I also have the SSL option set to "full":

View attachment 144912

Any ideas?
Some browsers will not display insecure content in a secure website.

So if you are linking to non ssl images somewhere inside of your ssl website then browsers will not display them. That is what the built in image proxy is for. It reroutes those external insecure images through your own, secure domain and reserves them to the browser.
 
#16
Some browsers will not display insecure content in a secure website.

So if you are linking to non ssl images somewhere inside of your ssl website then browsers will not display them. That is what the built in image proxy is for. It reroutes those external insecure images through your own, secure domain and reserves them to the browser.
Yes all I see is text but no formatting, and also I get the same http version of the site. I even tried to use this code to change the rewrite rules in my htaccess:

Code:
RewriteCond %{HTTPS} off
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
But it doesn't make any difference, I also changed the board url and I still get a blank page. Actually my board don't have any external images, everything is located in the database.

I would really appreciate any help. :)