1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 problems with likes

Discussion in 'Troubleshooting and Problems' started by loplo, Sep 17, 2015.

  1. loplo

    loplo Active Member

    I have some issues with likes, since I had to reinstall xf and reimport data.
    On some posts I have "2 people like this", I did like that message too, but I can't see who are those 2 people. In the meantime, I'm able to Dislike the post, and after pressing Like again, I get the following:
    You and (deleted member) like this.

    I have to mention, that no member has been deleted in the past days.

    Is this a known issue? Any workaround?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    How exactly did you reinstall and reimport data?

    What was the exact process you followed starting from when your forum was previously installed?
     
  3. loplo

    loplo Active Member

    After doing some test runs on my localhost, I've backed up data and internal_data, from my host, moved them to a temporary folder.
    Installed a clean xf into other database, without any other customization.
    After finishing install I went to Tools -> Import External Data, selected XenForo 1.2 13 1.4 and ticked Retain imported content IDs since it was a "naked" forum.
    Told the importer where the old database is and set the correct path to /data and /internal_data.
    The import finished without any issues NOR errors.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Why are you importing an existing XF forum into a new, empty XF forum?

    What is wrong with the existing forum?
     
  5. loplo

    loplo Active Member

  6. loplo

    loplo Active Member

    Anyone?
     
  7. Mike

    Mike XenForo Developer Staff Member

    It could be a bug with the importer. It isn't likely to be something that's fixable after the fact though, at least without doing another import. (In that case, importing while maintaining IDs may resolve it.) Alternatively, if accounts were merged in the import, that could potentially be relevant.

    In general, we wouldn't advise doing an import to attempt to resolve other issues. Uninstalling add-ons and creating a new, default style is generally sufficient for what most people are trying to do.
     
  8. loplo

    loplo Active Member

    During the import I ticked the box ref maintaing IDs.
    Unfortunately another import (of the old database&files) is excluded.

    Isn't there a way to find out which username is associated with the deleted account? I hope that there a glitch in the database and still fixable.
     
  9. Mike

    Mike XenForo Developer Staff Member

    You'll need to look in the database, in the xf_liked_content table to identify the post that you're looking at (you'll need the ID of that post) and then to see the user ID(s) that liked it. No username will be stored here though.
     
    loplo likes this.
  10. loplo

    loplo Active Member

    Found an example:
    like_id content_type content_id [​IMG] like_user_id like_date content_user_id
    4128 post 28373 13561 1431424469 13517

    The post ID is 28373, and the like_user_id is 13561.
    13561 is the user which is correctly shown, but I can't see anything else in the table.

    The forum shows: username "and (deleted member) like this."

    Any ideas?
     
  11. Mike

    Mike XenForo Developer Staff Member

    The content has been liked twice but since it only finds one user, it presumes the other user has been deleted. On that basis, there isn't really a way to identify who the other user was.
     

Share This Page