1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Problem with Use Full Friendly URLs

Discussion in 'XenForo Questions and Support' started by ViciousGnome, Jul 11, 2013.

  1. ViciousGnome

    ViciousGnome Active Member

    Hello, and thank you for trying to assist.

    When I registered my domain name, I installed vBulletin, and put the installation into a sub directory: www.mydomain.com/forums

    I have since switched to XenForo, and installed it in my root directory, however under

    Admin CP
    Options
    Basic Board Information
    Index Page Route

    There was an entry of /forums. I don't recall if i entered than upon installation,mor if it was a default option. Regardless, I have since removed this and saved, with no apparent consequences. A sample URL is:

    http://www.xdebate.com/index.php?forums/xdebate-of-the-week.2/

    Now, I deleted the database to my old vBulletin forums, but I never deleted the /forums directory in my website's root directory. Here is my issue: when I check off the "Use Full Friendly URLs" in my Admin CP, it removes the "index.php?" from the URL, making it:

    http://www.xdebate.com/forums/xdebate-of-the-week.2/

    Prior to deleting my old vBulletin forum database, that link brought me to my old vBulletin forum. However, since deleting my old vBulletin database, it produces the following error:

    There is a serious error and the page cannot be rendered

    How can I fix this, as I want to utilize the "Use Full Friendly URL" option.

    Again, thank you for any assistance you may provide.
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    Do you still have a directory named "forums" in the root of your XenForo installation containing files from your vB installation?
     
  3. ViciousGnome

    ViciousGnome Active Member

    Thanks.

    Yes, the /forums directory is still there. I'm afraid to remove it. XenForo was installed in my root directory. Can I delete the /forums directory, or delete all the files in it?
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    Just rename it to vbforums if you're concerned. Then if anything goes wrong you can rename it back again.
     
    CyclingTribe likes this.
  5. ViciousGnome

    ViciousGnome Active Member

    Thanks again. I'm going to try that. I'll post the results.
     
  6. ViciousGnome

    ViciousGnome Active Member

    It appears to have worked. Thank you very much! :)
     
    Chris D likes this.

Share This Page