• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Problem with page with Head Adsense

Cidrack

Active member
#1
Hi Guys...

When I put a adsense in the head I have this problem with logo:
https://www.dropbox.com/s/vvu9qos7esqju1v/Captura de tela 2014-06-19 06.37.04.png

And if I put this code in adsense to centralize:
<div style="position: absolute; margin-left: 450px; margin-top: 15px; width: 100%">

I Have this problem:
https://www.dropbox.com/s/1bh2f7w41ra1l6s/Captura de tela 2014-06-19 07.22.17.png

and:
https://www.dropbox.com/s/iwmo24upneq0rpv/Captura de tela 2014-06-19 06.49.14.png

How can I fix this?

Thank you for help.
 

Tracy Perry

Well-known member
#2
Maybe use the actual ad templates that are provided and then wrap them in a DIV that you can style?

Code:
<xen:hook name="ad_below_top_breadcrumb" />
<xen:if is="!in_array({$contentTemplate}, array('error', 'message_page', 'message_page', 'search_form', 'search_form_post', 'search_form_profile_post', 'xengallery_search_form_media', 'search_results', 'register_form','Foolbothoneypot_register_form', 'login', 'error_with_login', 'thread_view'))">
<xen:if is="!{$visitor.user_id}">
<p id = "adsense_ad_center">
<style>
.response-sample { width: 320px; height: 50px; }
@media(min-width: 500px) { .response-sample { width: 468px; height: 60px; } }
@media(min-width: 800px) { .response-sample { width: 728px; height: 90px; } }
</style>



<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Serving Linux header responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-xxxxxxxxxxxxx"
     data-ad-slot="xxxxxxxxxxxx"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</xen:if>
</xen:if>
And in EXTRA.css
Code:
/* Center adsense ads */
#adsense_ad_center {
display: block;
padding-top:8px;
padding-bottom:5px;
margin-left:auto;
margin-right:auto;
max-width: 900px;
}
Results in this
Screen Shot 2014-06-19 at 8.09.49 PM.png
 

Cidrack

Active member
#3
Hi @Tracy Perry Thank you...

I Was using this code:
<div style ="position: absolute; margin-left: 350px; margin-top: 15px; width: 100%"</div>

Now I tried this code:
<div style ="position: absolute; margin-left: 350px; margin-top: 15px"</div>

And now is ok.

Thanks.