1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Problem with new registrations (500 error register/register)

Discussion in 'Troubleshooting and Problems' started by ayushtyagi28, Sep 17, 2016.

  1. ayushtyagi28

    ayushtyagi28 Member

    Last edited: Sep 17, 2016
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Do you have access to the HTTP logs and the php-fpm logs? If so, you need to review them for any possible errors.
  3. ayushtyagi28

    ayushtyagi28 Member

    I have server logs from admin panel.

    ErrorException: Fatal Error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 7730150 bytes) - library/XenForo/Model/DataRegistry.php:155
  4. Tracy Perry

    Tracy Perry Well-Known Member

    Have you recently added any new add-ons - specifically any that deal with user registration?
    Have you recently done any PHP upgrades? Your PHP processor is getting an error and appears to be dying.
  5. ayushtyagi28

    ayushtyagi28 Member

    Nope nothing
  6. ayushtyagi28

    ayushtyagi28 Member

    Do you think that my DB might be full and running out of space?
  7. Tracy Perry

    Tracy Perry Well-Known Member

    No, odds are it's the php.ini setting, but something is exhausting your memory. What is your
    memory_limit = 128M
    is set at.
    If your DB/drive was full, you'd be getting a different error.
  8. Liam W

    Liam W Well-Known Member

    The error message states that the memory limit is set at 128MiB.

    Which is strange, as that's a decent memory limit. An add-on is trying to store a ridiculous amount of storage using the DataRegistry, and PHP is running out of allowed memory to store it before sticking it in the database.

    @ayushtyagi28 you could try increasing the memory limit (if you're on a dedicated/VPS server) to 256M. If you're on shared hosting, you'd have to ask your host kindly.

  9. Tracy Perry

    Tracy Perry Well-Known Member

    Yep, which is why I am scratching my head also over it as it shouldn't be. I'm leaning towards an add-on issue and maybe using PHP 7 or 7.1RC and it not being compatible.

Share This Page