1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Problem with Navigation Bar

Discussion in 'Troubleshooting and Problems' started by Nelson T., Mar 24, 2015.

  1. Nelson T.

    Nelson T. Guest

    On our forum: www.Hobby-Machinist.com:
    When you click any tab on the 2nd Command Bar except FORUMS, that tab switches from white on medium blue-gray to black on white, indicating that you are down somewhere under that tab. If you click on FORUMS, ADVERTISING switches from negative to positive instead.
    All bar colors mentioned are as seen in Style vBulletin 4.

    For the purpose of this thread (for want of knowing what XF calls them) the various colored bars that run all the way across the screen are as follows:

    Bars always at top of screen are:
    Medium blue-grey bar at top of screen is Top Command Bar.
    Medium blue-gray bar just below the 1st ad is 2nd Command Bar.
    Light blue-gray bar below 2nd ad is Upper Navigation Repeater Bar.

    Then there is whatever you are looking at or working on that may be only a screen high or 8 or 10 high.

    Always at almost the bottom of the screen (above only the XF copyright info) are:
    Medium blue-grey bar at bottom of screen is Bottom Command Bar.
    Light blue-gray bar just above that is Lower Navigation Repeater Bar.

    The reported problems are only with the Navigation Repeater Bars. The purpose of these bars is twofold. First, they are supposed to show you where on the site you are. Second, they are quick intermediate links back up the tree that you are in. For example, If you are reading a post in The Staff Lounge, you can click on The Staff Lounge to move up one level to see what other threads you need to read. If you wanted to go to Classifieds from The Staff Lounge or from a thread within, you can click on Members Area and then Classifieds. And until recently, if you needed to go to the Beginners forum, you could click on Forums and then immediately click on Beginners and there you were in only 2 clicks.

    The first problem (that none of us recognized earlier) is that there is no reason why Recent > should ever appear on the left end of both bars unless you are in Recent. If you click on most of the tabs on the 2nd Command Bar, (1) you get taken there and (2), the name of where you are (or in a few cases something sorta similar) appears on both Repeater Bars. However, unless you clicked on Recent, your location appears to the right of Recent >.even though you are not in Recent.

    The second problem or the exception to the above is that if you click on Forums, instead of Forums > appearing on the bar, Advertising > does. But you do get taken to Forums. Beyond that point, the rest of it works as it should (including that if you click on Advertising, you get taken to Advertising, not Forums). If you scroll down the screen and click on The Staff Lounge, you get taken into that forum and The Staff Lounge > appears on both NAV bars. And so on.

    How do we fix this please?
     
  2. Nelson T.

    Nelson T. Guest

    A related issue:

    Why is it that sporadically, the style button disappears and the display style changes to the pastel default? Then usually in about half a minute it changes back and the button in the bottom toolbar is back. As the first two times that it happened were at just shy of 02:00 CDT I at first thought it was something that happened every 24 hours. But then it happened maybe an hour ago.

    Anyone know why this is happening and how to fix this?
     
  3. Nelson T.

    Nelson T. Guest

    Can anyone please give me some possible insights on these issues, particularly the change in display styles?
     
  4. Mike

    Mike XenForo Developer Staff Member

    Unfortunately I'm really not sure what the issue you're trying to explain is. Can you show screenshots of the problem?

    The only real issue I see relates to the ad unit you've added at the top of the header, which is pushing the header down over the content (due to how it's implemented). The CSS for the height of the headerProxy needs to be changed (it's in public.css) to account for the extra height that has been added.
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Your 'home' tab is named 'Recent', hence why the breadcrumb shows that.

    upload_2015-3-24_19-54-46.png

    This appears to be related to an add-on or customisation, for several categories.

    http://www.hobby-machinist.com/categories/the-friendly-machinist-forum-site-rules-introductions.163/
    http://www.hobby-machinist.com/categories/general-machining-forums.11/

    http://www.hobby-machinist.com/categories/specific-manufacturer-forums.5/
     

Share This Page