1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Problem with creating new node and posting in it.

Discussion in 'Troubleshooting and Problems' started by ALMUSA, Nov 30, 2014.

  1. ALMUSA

    ALMUSA Member

    Ok, Im trying to create a forum under specific category and then post new thread in it but I couldn't. I click on post a new thread and then when I start typing the title, that little loading thing at the right top corner in the page won't stop loading. I click on create thread button but it does nothing however when I create a new forum under another category other than the one I'm talking about here, things seem fine and no problem whatsoever. Also Something strange happening in the ACP, it gets missed up for unknown reason. I disabled all the add one and still that won't solve the issue. Here is screenshot concerning this matter.

    [​IMG]




    [​IMG]
     
  2. Mike

    Mike XenForo Developer Staff Member

    These are almost certainly from mod_security triggering erroneously. It's likely based on something in the title -- if I had to guess, "GCC" as that's the name of a Linux compiler. Your host should be able to identify the rule that is triggering for your site and whitelist it for you. (You wouldn't be able to do this.)
     
  3. ALMUSA

    ALMUSA Member

    Thanks Mike, I guess that was the issue. I edited that acronym by putting dot in between and worked fine.

    Thanks again.
     
  4. ALMUSA

    ALMUSA Member

    Oh btw I have a quick question if you don't mind. How do I move nodes up and down. I by mistake deleted one of the node and now I want to put back to its place where it was but couldn't figure that out!
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Change the display order.
     
  6. ALMUSA

    ALMUSA Member

    I did but didn't work! what is the proper value should I use where it says ''display order''?
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    It is relative to the values set for other sibling nodes.
     
  8. ALMUSA

    ALMUSA Member

    All the values are set to 1. I have tried different numbers but didn't work either. Now when I create a forum it goes to the bottom of the page! :confused:
     
  9. ALMUSA

    ALMUSA Member

    Its actually a root node, it has no parent.
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    The values must be different.

    Lower to higher = top to bottom.
     
    ALMUSA likes this.
  11. Phases

    Phases Active Member

    If they all have the same display order they (probably) list in order of creation. So, set the display order for what you want. So if you have nodes:

    Fish
    Turtles
    Cake
    Bob

    and you want them in order: turtles, fish, cake, bob, you could try these display orders:

    Turtles: 100
    Fish: 200
    cake: 300
    bob: 400

    I would give 2 or 3 digit numbers to give room for growth and easy reordering after said growth. Depending on your site of course.
     
    ALMUSA likes this.
  12. ALMUSA

    ALMUSA Member

    Yeah that solved the problem.

    Thanks guys.
     
  13. ALMUSA

    ALMUSA Member

    Hi again,

    I checked once again and that issue still has not been solved yet. I emailed the host and after they investigated the error I received this email form them.


    Can you elaborate on what they meant by reverting the site/db to a previous date and what will happen if I ask them to do so.

    It seems like I have to deleted the node that contains ''GCC'' as a whole and recreate it once again with different title.

    Thank you Mike
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    They mean to revert to an older version of the database, which would mean any content created since that date would be lost.
    I wouldn't recommend that.

    This still appears to be mod_security related to you may want to consider changing hosts if they are unable to resolve it.
     
    ALMUSA likes this.
  15. Mike

    Mike XenForo Developer Staff Member

    The actual error is likely being hidden due to how your host has configured the ErrorDocument value and XenForo's rewrites. If you still have a setup that reproduces it and you'd like us to look into it, please submit a ticket with access to reproduce it and FTP details. I should be able to get a more specific error code to take to your host.

    I'm 99% sure that it is some sort of security/request filtering that they're doing.
     
    ALMUSA likes this.
  16. ALMUSA

    ALMUSA Member

    @Mike @Brogan

    Accept my apology for bothering you with this. The issue has been solved by the host. I just got this email from them.

    Thank you guys for your help. I do really appreciate it.
     

Share This Page