1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Problem sending mass email

Discussion in 'Troubleshooting and Problems' started by Shortie861, Mar 22, 2012.

  1. Shortie861

    Shortie861 Member

    Hi there, I am having a problem sending a mass email, I did a search and found a thread on here of someone else who was having the same problem and the reply suggested that the mysql may have been exceeded and to speak to hosting about increasing the following


    I have been onto my hosting and they have told me that they have increased them to

    max_allowed_packet = 10M

    However I am still getting the same error when attempting to send the mass email.

    I am wondering if this is enough to increase it to or should it be more?

    The error I am getting when sending the mass email is

    An exception occurred: Mysqli prepare error: MySQL server has gone away in /home/chataddi/public_html/library/Zend/Db/Statement/Mysqli.php on line 77
    Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
    Zend_Db_Adapter_Abstract->fetchOne() in XenForo/Error.php at line 50
    XenForo_Error::unexpectedException() in XenForo/Application.php at line 295
    Thanks in advance.
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You have the right idea. Those two MySQL settings are what cause the "gone away" error. If the error persists then try increasing those settings some more.

    Otherwise here is a more detailed writeup about that error (for your host):

  3. Shortie861

    Shortie861 Member

    Thank you :)

    Is there any rough idea of how high those settings should be or is it a case of change the settings until the problem goes?

  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Increase it until the problem goes away.

    The defaults are:

    wait_timeout = 28800
    max_allowed_packet = 1048576 (1MB)
  5. Shortie861

    Shortie861 Member

    Thank you, I shall get back onto my hosting and let them know see what they can do :)
  6. Shortie861

    Shortie861 Member

    They changed to the defaults and all seems to be working fine now :) managed to send a mass email with no errors and emails seem to have gone through :)


Share This Page