1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Problem in uploading avatars ( permission 600 )

Discussion in 'Troubleshooting and Problems' started by TBDragon, May 18, 2013.

  1. TBDragon

    TBDragon Active Member

    hi
    one of my friend forum have a problem when user upload an avatar its upload it
    but when he check the picture in the data folder
    he found it have the permission 0600 not 0644 !!
    and we talk with the host and they say the problem with the script >_< so how i can know if this problem from the script it self or the support guy don`t know how to solve it !!!

    =( hope u got what i mean and sorry for my english ..
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    TBDragon likes this.
  3. TBDragon

    TBDragon Active Member

    ya i did that
    but same error
    even if i open the avatar link

    its says

    Forbidden

    You don't have permission to access /data/avatars/l/0/215.jpg on this server.

    i make the data , avatars ,l and 0 folder permession 0777
    and same error =(
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Did you run these commands?
    Code:
    chmod -R 777 data
     
    chmod -R 777 internal_data
    If it still doesn't work, it could be an ownership issue.

    Is there anything in the Apache error logs?
     
    TBDragon likes this.
  5. TBDragon

    TBDragon Active Member

    ya already did that but from cPanel !! did this make different ?!


    in the error log

    there is

    [Sat May 18 11:17:12 2013] [error] [client xxxxxxxxxx ] (13)Permission denied: file permissions deny server access: /home/xxxxxx/public_html/xen/data/avatars/s/0/215.jpg
     

    Attached Files:

  6. Brogan

    Brogan XenForo Moderator Staff Member

    Are all of the sub-directories also 0777?
     
    TBDragon likes this.
  7. TBDragon

    TBDragon Active Member

    yes i did that =(
     
  8. TBDragon

    TBDragon Active Member

    check this =(
    the old pic i just change the permission but now
    even new avatar need to do it manually

    does this require some functions need to be enabled from the php.in ?!
     

    Attached Files:

  9. TBDragon

    TBDragon Active Member

    i try with him right now to make a fresh install
    and make the permission for both folder
    once i finish uploading the avatar its give same error
    so i just goes to the data folder which already have the 777 chmod
    and then i found the new folder
    avatars but !!!
    it was 755 chomd not !! 777 !!!!
    is there any solution from the root server ?! to tell the support to do it ?! >_<
     
  10. Mike

    Mike XenForo Developer Staff Member

    Ensure that you've followed what Brogan suggested. Then add this to then end of your library/config.php file:

    $config['chmodWritableValue'] = 0666;
     
    TBDragon likes this.
  11. TBDragon

    TBDragon Active Member

    =( same issue !!
    even with the fresh install >_<
     
  12. Mike

    Mike XenForo Developer Staff Member

    If you submit a ticket with admin CP and FTP details, I can look into it.
     
    TBDragon likes this.
  13. TBDragon

    TBDragon Active Member

    ="( the adminCP r in arabic >_<
    but its possible to have this problem on the server it self ?!
     
  14. router

    router Member

    i have the same problem. I did chmod settings but, m and s folders uploaded files, chmod 600 is set.
    ın l folders dont have chmod problem.
     
  15. Adam Howard

    Adam Howard Well-Known Member

    re-read this thread and the documentation 0600 is the wrong value.
     
  16. router

    router Member

    I know 0600 is wrong.
    I did chmod settings but m and s folders uploaded files, chmod 600 is set.
    ın l folders dont have chmod problem.
     
  17. Adam Howard

    Adam Howard Well-Known Member

    If chmod 600 is set, you need to fix this. 600 is not the correct value.
     
  18. Liam W

    Liam W Well-Known Member

    Do you have SSH access? If so, run the commands above. If not, you'll have to select all the files in the folder, and set their permissions (all read).

    Did you say files default to 600 when uploaded?

    Liam
     
  19. router

    router Member

    yes i have ssh access. i applied this commands but when i uploads a new avatars or attachment chmode option is 600.

    my default options are not 600. only here i upload this issue.
     
  20. Liam W

    Liam W Well-Known Member

    Hmm, strange. Sounds like something on the server. Could you contact your host and ask if there's something in the server configuration that causes PHP file uploads to be stored with the 600 permissions?

    Also, did you add the line in @Mike's post to your config file?

    Liam
     

Share This Page