1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Preinstalation problems

Discussion in 'XenForo Pre-Sales Questions' started by Nomce, Sep 11, 2011.

  1. Nomce

    Nomce New Member

    I have a server running CentOS 5.6, with virtualmin 3.

    Before I buy the XF script, I want to be sure that it will run on my server, so I checked with xenforo_requirements.php script, and there was a problem:

    Then, I followed this thread: http://xenforo.com/community/threads/simplexml-and-dom.5056/

    I updated php-common and php-xml, and the result was the same. Are there any other solutions instead of installing zend server?
  2. Slavik

    Slavik XenForo Moderator Staff Member

    What php version are you running?
  3. Nomce

    Nomce New Member

    PHP 5.3.8
  4. Mike

    Mike XenForo Developer Staff Member

    You may need to restart Apache after you install any extensions to PHP.
  5. Nomce

    Nomce New Member

    I restarted it thousand times. The result is same. :(
  6. Slavik

    Slavik XenForo Moderator Staff Member

    What repo are you using if any?

    Are you using yum?

    if you put

    <?php phpinfo(); ?>

    into a file and open it up do you have a DOM section?
  7. Nomce

    Nomce New Member

    I use yum, but I tried to use repo remi-test, as in the link, and when tried to update, there was an error: Not found.
  8. Slavik

    Slavik XenForo Moderator Staff Member

    What does typing

    rpm -qa |grep php
    remove the remi repo and just try running

    yum -y update php-xml
    yum -y update php-common

    if that fails, add the official centos testing repo

    Make a file called CentOS-Testing.repo in /etc/yum.repos.d/

    paste the following in

    name=CentOS-5 Testing
    then try updating.
  9. Nomce

    Nomce New Member

    php-common is updated,

    but even if I enter the command 'yum -y install php-xml', and then 'yum -y update php-xml', it says that the package php-xml is available, but not installed. Something weird happens here.
  10. Slavik

    Slavik XenForo Moderator Staff Member

    Can you post the ssh log?
  11. Nomce

    Nomce New Member

    Command: rpm -qa |grep php
    Command: yum -y update php-common
    [root]# yum -y update php-xml
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: gd.tuwien.ac.at
    * extras: gd.tuwien.ac.at
    * updates: gd.tuwien.ac.at
    Reducing CentOS-5 Testing to included packages only
    Setting up Update Process
    Package(s) php-xml available, but not installed.
    No Packages marked for Update

    Command: yum -y update php-xml
    Ok, now I read that for php-xml to install, there is missing dependency: php-common, but it is already installed.
  12. Slavik

    Slavik XenForo Moderator Staff Member


    yum -y install php-xml
  13. Nomce

    Nomce New Member

    I already tried that, but here it is again:
  14. Slavik

    Slavik XenForo Moderator Staff Member

    Will let you know when I get home. Am at poker at the moment.
  15. Scott

    Scott Active Member

    It's probably called php53-xml.

    yum list | grep php
  16. Nomce

    Nomce New Member

    Sorry for the late respond, but I didn't have internet yesterday.

    Scott, I tried that, but there is no change. The version which is already installed is 5.3.8, and with php53-xml command, installs the version 5.3.3 :S
  17. Slavik

    Slavik XenForo Moderator Staff Member

    Have you tried removing php-common then installing php-xml with the -y command to load the required php-common package automatically?
  18. Scott

    Scott Active Member

    You must have hand rolled PHP 5.3.8 which means you can't use yum to install the xml parts.

Share This Page