1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Posting a *link* to YouTube

Discussion in 'XenForo Questions and Support' started by ForestForTrees, Feb 10, 2013.

  1. ForestForTrees

    ForestForTrees Well-Known Member


    I love the way that Xenforo handles media site embeds. Is there a way that I can include a link to a media site such as YouTube. For example, perhaps I want to have a video start at a specific position or with a specific resolution. Or perhaps I just want people to read one of the comments. Is there a clever way to make this possible?

    Thanks in advance.
    EQnoble likes this.
  2. Chris D

    Chris D XenForo Developer Staff Member

    Just testing...

    Hmm that didn't work...

    YouTube Link

    EDIT: Ah yes, that works.

    Tactic is to write some text, highlight it, then use the insert link button on the editor and paste a YouTube link. This will change the text into a link to the YouTube video and it won't embed the video.
    Jake Bunce likes this.
  3. EQnoble

    EQnoble Well-Known Member

    thank you...you just gave me an idea :)
  4. ForestForTrees

    ForestForTrees Well-Known Member

    Thanks for the help, Chris. That works well.

    I tried posting the URL as the display text on the link, but that didn't work. That's fine, though.

    What I mean by the second sentence is that with a display text of "Random words" I get:
    Random words

    However, when I try to set the display text equal to the URL, the Media Site matcher kicks in and I get the video itself:

    Sometimes it is nice to have the URL display as the display text. I promise 10 internets to anyone who can make a link to a media site where the link URL is the display text.
  5. Chris D

    Chris D XenForo Developer Staff Member

    Jake Bunce likes this.
  6. ForestForTrees

    ForestForTrees Well-Known Member

    Looks great. Thanks for your help.

    10 internets to you!
    Chris D likes this.

Share This Page