• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Post Titles are not being checked against Spam Phrases entered in Spam Management

XFuser

Active member
#1
Hello,

The Spam Phrases in the Spam Management work great for text entered in the actual posts, but it is not working for phrases entered in the title.

For example, if you want to automatically moderate new links from new users, simply adding the Spam Phrase "http" will automatically moderate posts containing links from new users.

So what did the spammers start doing after we implemented that? They started entering the URL's in the Titles, and that's how we noticed this bug as those threads were being posted without being moderated.

Please fix this. Thanks.
 

Mike

XenForo developer
Staff member
#2
XenForo does not have "post titles", so I'm not sure what area you're referring to? Thread titles?
 

Chris D

XenForo developer
Staff member
#5
Unless a bug report has been marked as resolved, it's still open and potentially still something we are looking into.

FWIW, though, the code looks like both the title and message are checked, so in the first instance I would disable all add-ons and do some further testing.
 

Mike

XenForo developer
Staff member
#6
I can only guess this is from them editing the thread title after the fact. I have added a spam check to this step for the next release to catch this. As a workaround in the mean time, you could remove the ability to edit thread titles (for new members at least).

Thanks for your report.
 

XFuser

Active member
#7
I can only guess this is from them editing the thread title after the fact. I have added a spam check to this step for the next release to catch this.
Good catch. I look forward to the next version with this fix. Thanks.