1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Possible Attachment Bug

Discussion in 'Installation, Upgrade, and Import Support' started by a legacy reborn, Jan 7, 2011.

  1. a legacy reborn

    a legacy reborn Well-Known Member

    I am getting ready to release my site tomorrow and the one and only thing I have yet to go over...attachments! I tried to upload attachments first 2 at a time then 1 but havn't gotten it to work, so I increased my PHP Upload Limit and Attachment Upload limit in xF admincp and still nothing. please help :). I don't consider it crippling but I was wondering if it is a bug or something wrong on my side.
     
    AlexandrosD likes this.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Try adding this to your .htaccess file before the mod rewrite rules.

    Code:
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
     
  3. a legacy reborn

    a legacy reborn Well-Known Member

    Nope Didn't Work Hold on if it is mod_security I am going to completely disable it for the time being

    Edit:I turned it off and back on...wasn't the problem :(
     
    AlexandrosD likes this.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Another thing to check is the permissions on the /data and /internal_data directory and sub-directories.

    They should be 0777.
     
  5. a legacy reborn

    a legacy reborn Well-Known Member

    Wow...I feel like a r-tard it worked :) thanks for the help!
     
    AlexandrosD likes this.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    No worries, easy problems are good :D
     
    a legacy reborn likes this.
  7. Digital Doctor

    Digital Doctor Well-Known Member

    Why would software allow the attachments directory to not be writeable ?
    Isn't there any checking for that ?
    "Seems" like it would be easy.

    Or alternatively, can't there be an error message: Image upload failed, attachments directory not writeable ?
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    The installation process already takes this into account:

    Installation
    Upgrade
    If the permissions are changed after that point then that is usually when problems occur.
     

Share This Page