Poll Enhancement

Poll Enhancement v1

No permission to download

Shelley

Well-known member
Shelley submitted a new resource:

Poll Enhancement (version v1) - Poll Enahnceementnmwenqfikerhy

This derived from brogans icon replace in poll post and I thought I'd extend that and post a further enhancement by making the whole poll area a little more prominent. This alteration will change both the icon and the background.

Bare in mind, you can always change the colours to your own preference and/or style/site design.

First upload the poll.png icon into your widgets folder.
Secondly, Copy and paste the following into your EXTRA.css...
Read more about this resource...
 

RobParker

Well-known member
Just done this and it looks much better now, thanks :)

It might be worth pointing out that the widgets folder is in styles/<style_name>/xenforo/widgets/
 

SportainmentMG

Active member
Sorry Shelley,
I hate bothering you as I know you are a busy person but I meant the actual bar part of the poll currently #F9D9B0 I think.

But it doesn't matter you code has helped me to work it out :D
 

Shelley

Well-known member
Sorry Shelley,
I hate bothering you as I know you are a busy person but I meant the actual bar part of the poll currently #F9D9B0 I think.

But it doesn't matter you code has helped me to work it out :D
Ah no worries. try

Code:
.pollResult .bar {
    background: none repeat scroll 0 0 red !important;
}
.pollResult .barContainer {
    border: 1px solid green !important;
}
 

fredrikse

Active member
I thought the CSS code was going into the EXTRA.css template, which seems to be correct according to the instructions.
 

Shelley

Well-known member
Right now I have altered the CSS for my custom style. Should it be done in the standard xenForo style?
Yes, if your wanting the changes for any other style you'll have to included and add in the css in the styles extra css template.
 

MirrorMan

Member
I love the replacement icon, but for some reason the ? was still showing on top of it.

I fixed it by adjusting the .pollBlock .questionMark class

Replace:
Code:
    color: none !important;
    font-family: none !important;
    font-size: 0 !important;
With:
Code:
    text-indent: 40px;
    overflow: hidden;
 

Shelley

Well-known member
I love the replacement icon, but for some reason the ? was still showing on top of it.

I fixed it by adjusting the .pollBlock .questionMark class

Replace:
Code:
    color: none !important;
    font-family: none !important;
    font-size: 0 !important;
With:
Code:
    text-indent: 40px;
    overflow: hidden;
Thanks i'll have to re-visit a few resources in the future and make updates to them when and as time permits.
 

Shelley

Well-known member
For some reason I have a border around the image..

How do I remove this?
Are you sure it's a border and not a background-color? A screenshot or a link to your forum where the poll is located would help so I could debug the issue? I'm guessing what the issue is but try adding the following to your EXTRA.CSS template

Code:
#PollContainer .pollBlock .questionMark {background: none repeat scroll 0 0 transparent;}
 

Blatchy

Active member
Are you sure it's a border and not a background-color? A screenshot or a link to your forum where the poll is located would help so I could debug the issue? I'm guessing what the issue is but try adding the following to your EXTRA.CSS template

Code:
#PollContainer .pollBlock .questionMark {background: none repeat scroll 0 0 transparent;}
Yes I am quite sure.

 

Blatchy

Active member
This? (bolded part) do I completely remove it? Thanks

Code:
.pollBlock .questionMark {
    -moz-border-radius: 5px 5px 5px 5px;
    background: url("@imagePath/xenforo/widgets/poll.png")  no-repeat scroll 0 0 !important;
    color: none !important;
    font-family: none !important;
    font-size: 0 !important;
    height: 40px;
    left: 0;
    line-height: 40px;
    position: absolute;
    text-align: center;
    top: 0;
    width: 40px;
 
Top