1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Poll Enhancement v1

Poll Enahnceementnmwenqfikerhy

  1. Shelley

    Shelley Well-Known Member

    Shelley submitted a new resource:

    Poll Enhancement (version v1) - Poll Enahnceementnmwenqfikerhy

    Read more about this resource...
     
    resonansER, ArnyVee and RobParker like this.
  2. RobParker

    RobParker Well-Known Member

    Just done this and it looks much better now, thanks :)

    It might be worth pointing out that the widgets folder is in styles/<style_name>/xenforo/widgets/
     
  3. ArnyVee

    ArnyVee Well-Known Member

    Very cool touch :)

    Here is my before and after picture....

    Poll_Enhancement_01.jpg
     
    Shelley likes this.
  4. SportainmentMG

    SportainmentMG Active Member

    Do you know how we change the poll result color?
     
  5. Shelley

    Shelley Well-Known Member

    you want to be looking at .pollResults .count & .pollResults .percentage

    poll.png

    Code:
    .pollResults .count {
    color: red;
    }
    
    .pollResults .percentage {
    color: green;
    }
    
     
  6. SportainmentMG

    SportainmentMG Active Member

    Sorry Shelley,
    I hate bothering you as I know you are a busy person but I meant the actual bar part of the poll currently #F9D9B0 I think.

    But it doesn't matter you code has helped me to work it out :D
     
  7. Shelley

    Shelley Well-Known Member

    Ah no worries. try

    Code:
    .pollResult .bar {
        background: none repeat scroll 0 0 red !important;
    }
    .pollResult .barContainer {
        border: 1px solid green !important;
    }
    
     
    SportainmentMG likes this.
  8. fredrikse

    fredrikse Active Member

    Nothing happens when I paste the css code into the extra.css template. What might be wrong?
     
  9. ArnyVee

    ArnyVee Well-Known Member

    Make sure that you have placed the CSS into the right style template.
     
  10. fredrikse

    fredrikse Active Member

    I thought the CSS code was going into the EXTRA.css template, which seems to be correct according to the instructions.
     
  11. ArnyVee

    ArnyVee Well-Known Member

    Yes, but each style has its own EXTRA.css template.
     
  12. fredrikse

    fredrikse Active Member

    Right now I have altered the CSS for my custom style. Should it be done in the standard xenForo style?
     
  13. Shelley

    Shelley Well-Known Member

    Yes, if your wanting the changes for any other style you'll have to included and add in the css in the styles extra css template.
     
  14. MirrorMan

    MirrorMan Member

    I love the replacement icon, but for some reason the ? was still showing on top of it.

    I fixed it by adjusting the .pollBlock .questionMark class

    Replace:
    Code:
        color: none !important;
        font-family: none !important;
        font-size: 0 !important;
    With:
    Code:
        text-indent: 40px;
        overflow: hidden;
     
    Shelley likes this.
  15. Shelley

    Shelley Well-Known Member

    Thanks i'll have to re-visit a few resources in the future and make updates to them when and as time permits.
     
  16. Blatchy

    Blatchy Active Member

    For some reason I have a border around the image..

    How do I remove this?
     
  17. Shelley

    Shelley Well-Known Member

    Are you sure it's a border and not a background-color? A screenshot or a link to your forum where the poll is located would help so I could debug the issue? I'm guessing what the issue is but try adding the following to your EXTRA.CSS template

    Code:
    #PollContainer .pollBlock .questionMark {background: none repeat scroll 0 0 transparent;}
     
  18. Blatchy

    Blatchy Active Member

    Yes I am quite sure.

    [​IMG]
     
  19. Shelley

    Shelley Well-Known Member

    Check and remove the border in your extra.css which should be by .questionMark in your css code.
     
  20. Blatchy

    Blatchy Active Member

    This? (bolded part) do I completely remove it? Thanks

    Code:
    .pollBlock .questionMark {
        -moz-border-radius: 5px 5px 5px 5px;
        background: url("@imagePath/xenforo/widgets/poll.png")  no-repeat scroll 0 0 !important;
        color: none !important;
        font-family: none !important;
        font-size: 0 !important;
        height: 40px;
        left: 0;
        line-height: 40px;
        position: absolute;
        text-align: center;
        top: 0;
        width: 40px;
     

Share This Page