• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Phpbb3 to xenforo 1.2, avatars doesnt import

Adam Howard

Well-known member
#2
I pointed to the correct avatar directory and they didnt import. What can I do after the import or its gone?
You'll need to do the import over again (start over). I'm assuming this is an established phpBB community merging into a new XenForo install. If not, this is why you should test and backup first.

I had this problem once and the solution was simple.... chmod 777 the avatar / attachment folder and all its contents. This was more of a hosting configuration issue than anything else. But it was easy to resolve.

Double check the path and be sure to enter the full server path. A lot of people don't do that and I find that resolves a lot of import issues as well.
 
#3
Just checked and it seems all avatars have been imported to data/avatars
Inside the directory they are spread in 3 other folders s m and l
I asume this means small, middle and large.
But if they are imported succesfully what could be preventing them to show. I see some avatars appear, but very few. Could it be the size of the avatars? How can I change avatar options in xenforo admin panel?
 

Adam Howard

Well-known member
#4
Just checked and it seems all avatars have been imported to data/avatars
Inside the directory they are spread in 3 other folders s m and l
I asume this means small, middle and large.
But if they are imported succesfully what could be preventing them to show. I see some avatars appear, but very few. Could it be the size of the avatars? How can I change avatar options in xenforo admin panel?
When completing the import, the importer should rebuild all the cache. That is when some "lose ends" such as avatars seem to match up with the users.

If you're judging this step by step (while doing the import), you're not going to get the "full story" (big picture).

Of course it doesn't hurt to rebuild all your cache and search (last) once you've completed the import.
 

Mike

XenForo developer
Staff member
#6
Can you show an example of a user that has an avatar in the file system but where it's not showing in a thread/profile page? (We'd need the URLs to be able to see the content.)
 

Mike

XenForo developer
Staff member
#10
I don't see an avatar for your admin in the filesystem: http://www.betting-forum.com/xenfotest/data/avatars/l/0/1.jpg That was my main focus (users with an avatar in the file system that don't have one showing in XF).

Note that only custom avatars are converted (as XF doesn't have anything comparable to an avatar gallery). If the avatars were custom, I could only assume that either they couldn't be read from phpBB for some reason (permission issues) or perhaps they were from an add-on rather than a built in system? The fact that some avatars appear to have converted indicates that the directory was specified correctly but that there was some other reason for the others to not be imported.