XF 1.4 PHP less than 5.4


Well-known member
So there's a warning message now if upgrading a forum on a server that is running less than PHP 5.4. Is this warning message purely to encourage the user to prepare for xenforo 2.0, which will require PHP 5.4 or greater, or will some functionality of the current releases be impaired if PHP 5.4 or greater is not present?



XenForo developer
Staff member
Well PHP 5.3 and older is not being maintained by the PHP team itself, so you may have security flaws within PHP that are unfixed. (RedHat still maintains PHP 5.3 for security purposes, though you are relying on the fixes being backported which can get missed if the security implications aren't considered.)

There are occasionally features that work differently internally based on PHP versions. As it stands, most of these are 5.2 to 5.3 changes, but there may actually be ones that relate to 5.4 as well. (As an example, passwords are stored using a more secure system in PHP 5.3 and newer.)

On the whole, it's mostly preparatory and to promote good practices (in terms of server maintenance).