1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MG 1.1 Photopost import

Discussion in 'Media Gallery Support' started by DragonFlames, Oct 3, 2015.

  1. DragonFlames

    DragonFlames Active Member

    Hi,

    I recently imported a large Photopost system into XFMG. Generally it all went very well and I am very pleased with the results.

    I do have a couple of things I have not been able to solve that I think I should mention/ask about.

    Firstly, none of the ratings seem to have imported. I have tried rebuilds and so on but I don't think the data ever transferred across. At a push I could live without this info but it is a shame not to have it.

    My other problem, and the one that I really want to solve is re my videos.

    My 100+ videos all seemed to have made it over to XFMG. At first I didn't see any having come across but when I looked later there they all were, so that looked great. However when I came to run them all but 5 said they could not be run due to their format.

    So the videos have transferred over, and 5 play fine. The rest all say they are not in a format that can be displayed.. I found I can download the original video using the download button in all those cases, and they seem to be things like .WMV or .MOV All the videos have their correct owner, views, and other info (apart from ratings).

    I downloaded a few and tried uploading them afresh and they went off into the transcode system as expected. I got some alert messages back a day later saying they failed. Others I have tried since have not gone live and have so far not produced any alerts either. None of this has produced any server error messages.

    So, I tried downloading some and using Movie Maker to read them in and then publish them as .mp4 files. That worked very quickly and the .mp4 uploads into the system that I tried also worked just fine. Sadly though with my name not the owners, a new date, and none of the old wanted info and details of course.

    So I seem to have the following problems:
    No ratings
    No way to update the videos from their old files to new .mp4 ones
    No working transcode system

    When I did the import I had entered the path to my php install by entering whereis php into my server and using the first path info that provided. When these video problems came up I tried which php on the server and entered that different path instead. FFMPEG seems OK as it is making thumbnails. I only installed the one file for that.

    I hope this all makes sense and you can help. For now I have made video uploads .mp4 only and I have hidden all the non working videos, so this isn't causing me massive grief that needs a very fast solution.

    Steve
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    The videos importing, I'm not actually sure we explicitly intend to import video files at all though I need to check this to be sure. We certainly wouldn't transcode them during import, we would assume they were already in a format to be playable.

    What version of the Gallery are you running at the moment, and what version were you running during the import? What version were you running when you set up FFmpeg? We did change the way the FFmpeg requirements were checked in 1.5.1. If you're not already running this, you should upgrade. Then, go to check the transcode settings to verify the FFmpeg path is correct and click save (even if you haven't changed anything). This should do a better job of verifying the FFmpeg requirements are correct.

    If not, this could well explain why the videos weren't transcoding correctly when you tried to re-upload them.

    In terms of ratings not importing, what version of PhotoPost did you import from? Is the xengallery_ratings table actually empty (or at least was it after the import)? We haven't had similar reports of ratings not importing before so I'm currently not sure what would cause that.
     
  3. DragonFlames

    DragonFlames Active Member

    Chris,

    Thanks for the speedy reply. Didn't expect that on a Saturday evening I have to say.

    The videos imported really well all things considered.

    All the videos were in whatever format they were uploaded in and Photopost has no system to change formats as such so I doubt if you'd normally get any imports where the videos were all already in MP4.

    I guess you probably face a lot of future imports where videos will be involved now PP has gone the way it has and with you having videos as one of the media types in XFMG.

    All my XF software versions are the latest. So XF 1.5.1 and XFMG 1.1.1. PP was 8.42

    Your checks were happy with the 64 bit FFMPEG I have now, and with another version of it I tried. Also your checks passed the path to the PHP binary with either of the paths I used - to two different binaries it seems. I did make an error on the path to PHP when I first typed it in and it rejected that so I was aware it was checking something about it.

    I just deleted those paths and saved and then entered them in again a moment ago and they were again accepted. I'd doubt the PHP one most and if you know a simple way for me to check I now have the correct PHP path you want used, via a server command or by looking at the Php info file or anything please say. Likewise with FFMPEG, if you have a file you know works and you want me to use that please just put it somewhere on here I can get it or whatever. It is working for thumbnails anyway and came from the source you suggested on here so that makes me think it is probably not that which is a problem. Not seeing any detailed error messages makes it hard to know what is failing though.

    I got another fail alert this evening for one of the files I uploaded this morning. I don't know why it is taking so long to say anything as they are very small files for videos that I am trying, like 10mb max. I think those should convert very quickly.

    Just had a look at the database and Xengallery_rating has nothing at all in it apart from one entry I have made by rating an image yesterday.

    Thanks for your help.

    Steve
     
  4. DragonFlames

    DragonFlames Active Member

    ...just for further info I got these today from the video uploads I tried yesterday:

    Unfortunately, the video file you uploaded named Test could not be processed. Please upload a different video and try again.
    11:15 AM

    Unfortunately, the video file you uploaded named Fireworks could not be processed. Please upload a different video and try again.
    11:14 AM

    Unfortunately, the video file you uploaded named TheNet could not be processed. Please upload a different video and try again.
    11:12 AM

    A couple of thoughts I can mention - all the non working videos that transferred over seem to have thumbnails created by XFMG using FFMPEG so I guess that proves that it is working and can work with all those files.

    One problem I have encountered is when I am looking for small file size videos to use for tests I have noticed the system seems not to tell me any of the file sizes...unless I am missing something. That is a real surprise, I would have expected it to be in the Information section top right but there seems to be no way of knowing if a video is 1mb or 500mb.. which makes it hard for what I am trying to do but also for those deciding what to watch or download or whatever.

    I still guess this transcoding problem may be connected with the attempt to aim the PHP code at a specific PHP binary somehow. If it could just run normally on a small file in a more normal way perhaps that would prove/show something....happy to try anything. Sorry for any silly guesses/ideas...and still no rush on this stuff.. I just wanted to pass on a little further info.

    Steve
     
  5. Chris D

    Chris D XenForo Developer Staff Member

    Hi Steve,

    Thanks for the further info.

    The ratings table being nearly empty is very odd - we've not had any similar reports of this failing so we may need to look at the source data to work out why this is. Depending on the PhotoPost version, the ratings should be coming from either the comments or ratings table. I believe recent versions of PhotoPost had a separate ratings table, but older versions stored it in the comments table. The annoying possibility that is springing to mind is if the ratings from the comments table weren't imported into the ratings table when updating from the older version of PhotoPost to the newer version. I guess the easiest way to check this, is, do you have a ratings table in PhotoPost? And if so, is it empty? And if it is empty, are the ratings in the comments table? Was the move to PhotoPost 8.x a recent change?

    Generally it should be possible to find the correct php binary by running the command "which php" from your shell on the server. In retrospect there isn't much within the code that verifies the PHP binary (other than the path and file you specify exists). We may need to try and do some better detection of that. That said, I'm still not entirely sure it's the problem. Can you try and upload the video files here? If they fail here, too, then it could be indicative of some other problem.
     
    Last edited: Oct 4, 2015
  6. DragonFlames

    DragonFlames Active Member

    Chris,

    My PP had its own database and I just went and had a look. Ratings are stored in the Ratings table and they are all there fine. There are not very large numbers of them. I have to wonder if I went around on XFMG and rated the same items, and then went into the database and changed the ID of the rater to the correct original one whether that would remove my problem on that. I could maybe just type them all into the database from scratch I guess. They are 0-10 ratings of course so I guess I would need to roughly halve them.

    On the same basis, if I convert the old videos by hand and upload them afresh I presume I can perhaps then go into the database and change the uploader and date info one by one and so on to match the original and all may be as needed.

    That 8.42 PP version I have was installed about a year back and the only one they have done since then has what appear to be minor changes and can not be downloaded by me since they ceased allowing renewals of support and so on.

    I did a test upload of a small WMV video here and it worked fine and as expected so I deleted it again. I tried the same one on my system and it is off with the fairies again... :) I got through another fail notice for one I tried yesterday just now so I suspect each upload may be locking up that system for a day at a time.

    I am wondering what is different on my system. One thing is my server uses a socket to connect with the database and so on. I tried the recommended settings for that when installing XenForo but it would only accept Localhost and not anything after that to define the socket being used. I reported it here at the time I think. I found a simple way around that and it was entering into the XenForo config file a line saying ini_set('mysqli.default_socket', 'myroute.sock'); It all worked fine then and all of XF, XFMG, and all addons etc worked well.

    I do wonder if this video transcode system tries to step outside the normal PHP settings and so won't run due to this socket setting not then being active, or due to some other setting. Hard to guess, still no error messages in the XF server log.

    Steve
     

Share This Page