Not a bug Patch Requested

Sam F

Active member
Patch Requested

Try to find and remove any instances of "intval" that you find in that template (You can leave the parenthesis in place)

I wish there was a nicer way we could fix this, it's sort of a catch-22, if we don't distribute it with the intval in place people get warnings in PHP 7.1, and if we do have it people get errors in XenForo 1.5.8 and below, the best case fix would be to upgrade XenForo to at least 1.5.9, or if The XF developers released a patch that could be applied to lower versions to add support for this function.
https://xenforo.com/community/threads/th-donate-multi-campaign-manager-paid.103199/page-36#post-1133648
 

Sam F

Active member
Easiest fix would be to just upgrade your XenForo to 1.5.9+ ?

Are you unable to upgrade right now?
I agree, you should just update XenForo.
I was just bringing this to the attention of the developers, they should know that a correction in their code would not effect customers that use other add-ons like Campaign manager. There also is other things going on.

Like the below error log, which when you remove it, just comes back. and the below rebuild which keeps trying to install, but keeps crashing, and you cannot keep it from trying to rebuild. then when you go to install or update another add-on, the below started again, and keeps happening.

so I patch may keep this from happening?

Thanks
upload_2017-2-18_3-45-0.png




An exception occurred: addm.css - Line 30: Invalid math expression in /*******/*******/public_html/*******. com/forums/library/XenForo/Template/Compiler.php on line 991

  1. XenForo_Template_Compiler->getNewCompilerException() in XenForo/Template/Compiler/Function/Calc.php at line 189
  2. XenForo_Template_Compiler_Function_Calc->_parseMathExpression() in XenForo/Template/Compiler/Function/Calc.php at line 55
  3. XenForo_Template_Compiler_Function_Calc->compile() in XenForo/Template/Compiler.php at line 700
  4. XenForo_Template_Compiler->compileFunction() in XenForo/Template/Compiler.php at line 576
  5. XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
  6. XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 372
  7. XenForo_Template_Compiler->compileParsed() in XenForo/Model/Template.php at line 1601
  8. XenForo_Model_Template->compileAndInsertParsedTemplate() in XenForo/Model/Template.php at line 1379
  9. XenForo_Model_Template->compileTemplateInStyleTree() in XenForo/Model/Template.php at line 1329
  10. XenForo_Model_Template->compileNamedTemplateInStyleTree() in XenForo/Model/Template.php at line 1268
  11. XenForo_Model_Template->compileAllTemplates() in XenForo/Deferred/Template.php at line 36
  12. XenForo_Deferred_Template->execute() in XenForo/Deferred/Atomic.php at line 66
  13. XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 295
  14. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 429
  15. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 374
  16. XenForo_Model_Deferred->run() in XenForo/ViewRenderer/Abstract.php at line 352
  17. XenForo_ViewRenderer_Abstract::hasManualDeferredToRun() in XenForo/ViewRenderer/HtmlAdmin.php at line 130
  18. XenForo_ViewRenderer_HtmlAdmin->renderContainer() in XenForo/FrontController.php at line 637
  19. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  20. XenForo_FrontController->run() in /*******/*******/public_html/*******. com/forums/admin.php at line 13
 

Nudaii

Well-known member
older versions of xf in the same second digit series aka 1.5.x dont get patches, sometimes they will release a security fix for 1.4.x etc,
 

Mike

XenForo developer
Staff member
The add-on you're installing simply requires a newer version of XenForo. Ideally, this would be handled in the add-on's installer code so it would block you from attempting an install/upgrade if you didn't meet the requirements.

You may be able to try to import an older version of the add-on, though I'm not confident that would work as we don't generally allow downgrades. The only other fix from our point of view would be a XenForo upgrade. The add-on developer may have other workarounds (like mentioned the first post).
 

Sam F

Active member
The add-on you're installing simply requires a newer version of XenForo. Ideally, this would be handled in the add-on's installer code so it would block you from attempting an install/upgrade if you didn't meet the requirements.

You may be able to try to import an older version of the add-on, though I'm not confident that would work as we don't generally allow downgrades. The only other fix from our point of view would be a XenForo upgrade. The add-on developer may have other workarounds (like mentioned the first post).
Thanks, I was just quoting what the add-on developer stated here:

Try to find and remove any instances of "intval" that you find in that template (You can leave the parenthesis in place)

I wish there was a nicer way we could fix this, it's sort of a catch-22, if we don't distribute it with the intval in place people get warnings in PHP 7.1, and if we do have it people get errors in XenForo 1.5.8 and below, the best case fix would be to upgrade XenForo to at least 1.5.9, or if The XF developers released a patch that could be applied to lower versions to add support for this function.
https://xenforo.com/community/threads/th-donate-multi-campaign-manager-paid.103199/page-36#post-1133648
 

Sam F

Active member
Ideally, this would be handled in the add-on's installer code so it would block you from attempting an install/upgrade if you didn't meet the requirements.
Mike, I should added that I appreciate your pointing this out to me, so now I can contact the add-on developer and bring this point out to them for not having such a install version checker.

The add-on developer may have other workarounds (like mentioned the first post).
I think you may have read the first post wrong, it was the add-on developer who was sending me to you for a patch, because they have looked at the install ( from within my Admin panel ) and do not have a solution?.

At this point it seems like there is know way to get rid of those error messages from popping back up, or keep from having Xenforo trying to rebuild the install? everytime I try to update a different add-on.

so I will have no other alternative but to update you Xenforo.

But it would have been nice to be able to have a way to get ride of the error and rebuild notices.
 

Sam F

Active member
What is wrong with updating XenForo?
Nothing, just that what Mike pointed out, is the issue at the moment.
So now I know, why this occurred and who's fault it was for not having added a version checker in there installer.

Ideally, this would be handled in the add-on's installer code so it would block you from attempting an install/upgrade if you didn't meet the requirements.
 
Top