1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Page not found

Discussion in 'Troubleshooting and Problems' started by Phinary, Apr 3, 2013.

  1. Phinary

    Phinary New Member

    Hey. I am not sure what would cause this. I have tried messaging the maker of my template that I use, and he had no idea either. I tried rebuilding my templates along with other things and nothing worked.

    Basically my problem is that when I go to a forum post, and click the edit button as displayed here:
    [​IMG]
    (The edit button below the thumbs up)
    It has a loading image for about half a second, then a popup comes up saying the page could not me found:
    [​IMG]

    My website is ezpvp.com


    My addons:
    [​IMG]

    If anyone has any idea on what would cause this and/or how to fix it please let me know.

    Thanks!
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    If you turn JavaScript off, and click "edit" can you see the page? If not, what is the URL that you are seeing?
     
  3. Phinary

    Phinary New Member

    If I turn javascript off, there is no edit button. The normal edit inside the post works fine, but when looking at the post through the forum view and clicking the edit link (as shown in the picture i posted) it does not work :/
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    Can you right click and tell us what the route for the Edit link is? It seems like its looking for a specific route it can no longer find. The correct route to AJAX edit a post should be:
    /posts/ID/edit
     
  5. Phinary

    Phinary New Member

    It just says javascript: at the bottom of the page. If i try to copy the link, it doesn't copy anything
     
  6. James

    James Well-Known Member

    The issue seems to be that its not picking up the link then. Obviously we can't debug this because nobody has edit privileges as a guest.

    Check the template thread_list_item (if it's a manual edit) or check the relevant add-on.
     
  7. Phinary

    Phinary New Member

    I am guessing this has some relevance:
    <xen:if is="{$thread.canEditThread}"><a href="javascript:" data-href="{xen:link 'threads/list-item-edit', $thread}" class="EditControl JsOnly">{xen:phrase edit}</a></xen:if>

    Edit: After further testing, it works with every skin except this one. Going to check that thread_list file in comparison to the other skins

    Alright, awesome. That line was the issue. Just replaced that line with the same one from another skin I had and it worked fine. Thanks!
     
  8. James

    James Well-Known Member

    Hmm, not sure why it's using data-href. You can just put the link in the href and apply a class of OverlayTrigger.
     

Share This Page