[OzzModz] Post Areas

[OzzModz] Post Areas 2.1.2

No permission to download

Ozzy47

Well-known member
I'm unsure why is has sporadic issues. Really hard to track down when it's not easily replicated.
 

gogo

Well-known member
How can I make it used as an admin monitor tool rather than viewable by all members? That means it's only viewable by admins..

Using cache or not won't be a problem if it's solely used by admin. And I don't want members get analyzed by other members so easily by using this add-on.
 

imno007

Well-known member
How can I make it used as an admin monitor tool rather than viewable by all members? That means it's only viewable by admins..

Using cache or not won't be a problem if it's solely used by admin. And I don't want members get analyzed by other members so easily by using this add-on.
It shouldn't be much of a problem, as far as the caching goes, it will just take an extra second or two to load on member's who have created a lot of threads/posts. As far as getting "analyzed" by other members, I think of it as an aid to content discovery, and actually promote it in a little video I put together for that purpose. Even without the addon, other members can still see everything other members have posted, if their profiles aren't private, just not as easily by node.
 

Ozzy47

Well-known member
So far the new version seems to be doing much better in performance. I’d still like some more testers that were having issues.
 

spirogg

Active member
When you click on a member in my case administrator and go to the profile page
if you click on the links below

Latest activity. postings. post areas about

I believe the Post Areas link is the one throwing the error in ACP


I click on all of the links starting from left to right and then right to left and left to right

and I get this error code just FYI


Code:
Server error log
ErrorException: [E_NOTICE] Undefined offset: 25

src/addons/Awedo/PostAreas/Model/PostAndThreadStats.php:59
Generated by:

Feb 28, 2021 at 12:30 AM
Stack trace

#0 src/addons/Awedo/PostAreas/Model/PostAndThreadStats.php(59): XF::handlePhpError(8, '[E_NOTICE] Unde...', '/home/tk...', 59, Array)
#1 src/addons/Awedo/PostAreas/XF/Pub/Controller/Member.php(26): Awedo\PostAreas\Model\PostAndThreadStats->getPostAndThreadCountsFromCache('1')
#2 src/XF/Mvc/Dispatcher.php(350): Awedo\PostAreas\XF\Pub\Controller\Member->actionPostAreas(Object(XF\Mvc\ParameterBag))
#3 src/XF/Mvc/Dispatcher.php(257): XF\Mvc\Dispatcher->dispatchClass('XF:Member', 'PostAreas', Object(XF\Mvc\RouteMatch), Object(Awedo\PostAreas\XF\Pub\Controller\Member), NULL)
#4 src/XF/Mvc/Dispatcher.php(113): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(Awedo\PostAreas\XF\Pub\Controller\Member), NULL)
#5 src/XF/Mvc/Dispatcher.php(55): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#6 src/XF/App.php(2326): XF\Mvc\Dispatcher->run()
#7 src/XF.php(488): XF\App->run()
#8 index.php(20): XF::runApp('XF\\Pub\\App')
#9 {main}
Request state

array(4) {
  ["url"] => string(158) "/members/tkwager.1/postAreas?_xfRequestUri=%2Fmembers%2Ftkwager.1%2F&_xfWithData=1&_xfToken=1614493803%2Ce42030f438d56a5837e0ab773e128da4&_xfResponseType=json"
  ["referrer"] => string(42) "https://www.tk.com/members/tkwager.1/"
  ["_GET"] => array(4) {
    ["_xfRequestUri"] => string(19) "/members/tkwager.1/"
    ["_xfWithData"] => string(1) "1"
    ["_xfToken"] => string(43) "1614493803,e42030f438d56a5837e0ab773e128da4"
    ["_xfResponseType"] => string(4) "json"
  }
  ["_POST"] => array(0) {
  }
}
 

MisakiTaro

Active member
If you installed the add-on but It says "This user hasn't posted any messages yet." run the Cron Entry manually.
 

krieglich

Member
I think redirects don't work properly in this add-on. Forums with redirected threads show up in the list with the number of those threads, but if you click on that number the result is empty.
 
Top