• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Optimize Mappings

Sunka

Well-known member
#1
I am using latest version of ellasticsearch and enhanced search.
One confusing element is that I have an option in tools => elasticsearch setup to Optimize Mappings.
When I click on that, nothing happened.

I tried delete index, then click on Optimize Mappings and then rebuild search, but this option allways show again in tools => elasticsearch setup
 

Mike

XenForo developer
Staff member
#3
I don't have any issues with this in Elasticsearch 2.0.0. We did run into this in the past version, but it was fixed a while ago. Can you confirm the versions involved?
 

RoldanLT

Well-known member
#5
Click on Optimize Mappings, nothing happen then Check the check box Delete index, then Delete Index.
Should work as expected.
 

Sunka

Well-known member
#6
Click on Optimize Mappings, nothing happen then Check the check box Delete index, then Delete Index.
Should work as expected.
Nothing changed.
clicked:
Optimise mappings
check delete index
delete index
(optimise mappings opition is still there)
rebilding search
 

Mike

XenForo developer
Staff member
#8
I've just tried to confirm this with Elasticsearch 2.1.0 and it has worked without issue, so I don't believe it's specific to that. Did this work with a previous version of Elasticsearch/XFES add-on?
 

Sunka

Well-known member
#9
I installed xfes just about week ago. First few days was on elastictic search 1.7 and XFES 1.1.2 and there was no problems, then I update to elastic search 2.1 and XFES 1.1.3 and that was first time that I see that option (Optimize Mappings) showing in ACP.
Whatever I do, that options stay there, like optimization is never done
 

Mike

XenForo developer
Staff member
#10
I can try to look into it. I'd need to be able to debug the code though, so I'd need ACP and FTP access. Can you submit a ticket with this information?
 

MstrfBlng

Active member
#12
Any updates? My 'Optimize mappings' button shows up too. XFES 1.1.3 and ES 2.1.1

Odd thing is my XFES installation is 3 hours old. :)

Pressing the button doesn't seem to do anything and it also doesn't disappear.
 

Sunka

Well-known member
#15
Yep, autocomplete is working.
If I turn off this addon, then when deleting index and rebuild search, optimize mappings is not showing any more.
I managed this way. Uninstall your addon, delete search index, rebuild search, install your addon, save setting for your addon, delete index again, rebuild search index again.

I think that this kind of "error" is related with upgrading elastic search and enhanced search addon when your addon is installed on server. Probably I am wrong (y)