OpenXBL

OpenXBL 1.5

No permission to download

TACTICS

Active member
TACTICS submitted a new resource:

OpenXBL - Xbox Live for XenForo

Allow your users to authenticate and associate their Xbox Live profile with their account. They will be able to login using this method thanks to OpenXBL - an open source Xbox Live API. How is this possible? Microsoft has a public API already it just has no documentation so you are left to your own devices when trying to make sense of it all. OpenXBL takes care of that for you and provides a quick and easy to use API that takes the mess out of figuring it out.

Features
  • ...
Read more about this resource...
 
  • Like
Reactions: PXB

[xFv]

Previously Cylent1
Nice!
Can't wait to try this out.
Wonder if we could get one for Nintendo Network?
 

TACTICS

Active member
Hi @Cylent1, thank you for the nice comments. Let me know how it works for you!

I do not have much experience with the Nintendo Network but I will definitely take a look and let you know if that's a possibility.
 

CoZmicShReddeR

Well-known member
I'm not sure what going on set up the Microsoft app and put all what I thought was the correct info into the OpenXBL site... I am sure if I am the only one have issues I put the wrong information in somewhere...

Removed attachment had sensitive info
 

TACTICS

Active member
I'm not sure what going on set up the Microsoft app and put all what I thought was the correct info into the OpenXBL site... I am sure if I am the only one have issues I put the wrong information in somewhere...

Removed attachment had sensitive info
Hi @CoZmicShReddeR,

I've put together a tutorial video on how to setup the Microsoft information it can be found here:
https://xbl.io/training/xboxapp

Then you put the Application Key in the OpenXBL settings in the XenForo admin panel. Let me know if you're still having trouble.

UPDATE:

After visiting your website I noticed the popup login. It didn't look correct and made me discover a typo in one of the template modifications. I uploaded a new XML file to GitHub to fix this issue.

Additionally, I manually went to the URL that uses OpenXBL to login to your website and the error you're getting back is the 'client_secret' being wrong. That value should match what you have in the MSA Developer Portal as seen in the tutorial video.
 
Last edited:

CoZmicShReddeR

Well-known member
Hi @CoZmicShReddeR,

I've put together a tutorial video on how to setup the Microsoft information it can be found here:
https://xbl.io/training/xboxapp

Then you put the Application Key in the OpenXBL settings in the XenForo admin panel. Let me know if you're still having trouble.
I watched the how too video reviewed everything doesn't seem to want to work...

I hope you don't mind I sent you connection information to look at to double check as I am sure I put everything in correct place but might have missed something...
 

TACTICS

Active member
TACTICS updated OpenXBL with a new update entry:

New Features + Bug Fixes

  • Added login button to login bar / drop down.
  • Fixed an issue that would override the sidebar login/register button.
  • [NEW] Added custom page for new users who still need to create an Xbox account (template name 'openxbl_no_xbox_profile').
  • Removed an installation step that had you manually enter your URL in openxbl.php.
  • [NEW] Added the ability to properly address error codes.
Read the rest of this update entry...
 

CoZmicShReddeR

Well-known member
Could you please look into giving an option to show or not show the login on the [Sign up now!] side block?

Plus might be me but I am seeing Facebook icon on the Xbox Live bar?Screen Shot 02-05-17 at 12.19 PM (2).PNG
 

TACTICS

Active member
Last edited:

TACTICS

Active member
@TACTICS I tried several times to update it from the GitHub account it isn't version 1.3 and whatever that file is it's says it's not a installer file
@CoZmicShReddeR,

Sorry to hear about that! Did you upload all the updated files in GitHub (not only the XML file) to your web server?

Then head over to Home > Add-ons. There look for 'OpenXBL' and hover over 'controls' and click 'Upgrade Addon' where you browse your desktop and select the XML file.
If that still causes you problems can you screenshot the error? Thanks!

Edit: for some reason the XML file version read 1.2.1 but is in fact 1.3 just the version string was incorrect. I did make this change and uploaded the new XML file to GitHub.

- TAC
 
Last edited:

CoZmicShReddeR

Well-known member
Downloading it and installing it shows version 1.2.1

The 1.3 version of addon-OpenXBL.xml says it's not addon Error The provided file was not a valid XML file. Please provide a valid XML file.


Screen Shot 02-13-17 at 08.29 PM (2).PNG
Screen Shot 02-13-17 at 08.31 PM (2).PNG
 

TACTICS

Active member
Uploading stuff to GitHub can be weird sometimes. I've put a new XML file up directly through GitHub 'upload' feature to ensure they dont mess with the encoding.
 
Top