1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Opening alerts triggers "Invalid UTF-8 sequence" error

Discussion in 'Troubleshooting and Problems' started by jflory7, Feb 9, 2015.

  1. jflory7

    jflory7 Active Member

    Hello XenForo forums,

    I've recently had an issue with my opening my alerts on my site today. Whenever I mouse over the alerts, I am given a stacktrace that is related to this error in my ACP:

    Server Error Log
    Error Info
    ErrorException: json_encode(): Invalid UTF-8 sequence in argument - library/XenForo/ViewRenderer/Json.php:188
    Generated By: JWF, 4 minutes ago
    Stack Trace
    #0 [internal function]: XenForo_Application::handlePhpError(2, 'json_encode(): ...', '/var/www/crysta...', 188, Array)
    #1 /var/www/crystalcraftmc.com/public_html/library/XenForo/ViewRenderer/Json.php(188): json_encode(Array)
    #2 /var/www/crystalcraftmc.com/public_html/library/XenForo/ViewRenderer/Json.php(104): XenForo_ViewRenderer_Json::jsonEncodeForOutput(Array)
    #3 /var/www/crystalcraftmc.com/public_html/library/XenForo/FrontController.php(586): XenForo_ViewRenderer_Json->renderView('XenForo_ViewPub...', Array, 'account_alerts_...', NULL)
    #4 /var/www/crystalcraftmc.com/public_html/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_Json), Array)
    #5 /var/www/crystalcraftmc.com/public_html/index.php(13): XenForo_FrontController->run()
    #6 {main}
    Request State
    array(3) {
      ["url"] => string(169) "http://crystalcraftmc.com/account/alerts-popup?&_xfRequestUri=%2F&_xfNoRedirect=1&_xfToken=1%2C1423484997%2C532e7c477600d0110f1c404fc96617f23904d956&_xfResponseType=json"
      ["_GET"] => array(4) {
        ["_xfRequestUri"] => string(1) "/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfToken"] => string(53) "1,1423484997,532e7c477600d0110f1c404fc96617f23904d956"
        ["_xfResponseType"] => string(4) "json"
      ["_POST"] => array(0) {
    I tried using this on the default XenForo theme and my custom styles to no avail — I still get the same result. Can anyone help direct me from where to go from here to figure out this problem? I'm trying to figure out the next step. Thanks!
  2. Mike

    Mike XenForo Developer Staff Member

    What about if you disable add-ons?

    If you go to the full alerts page (<url>/account/alerts), what happens? Is there any weird looking content on the page?
  3. jflory7

    jflory7 Active Member


    As always seems to be the case, I left my desktop this morning, came home, and found that the alerts seem to be working fine now. I had rebuilt all of the different caches in the ACP right before I left. But now, it seems that it isn't repeatable.

    Anyways, for possible future reference, opening the Alerts page worked fine for me even when the pop-up did not. I didn't notice any strange characters or foreign text that could have triggered it.

Share This Page