1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Now-deleted Guestuser not displayed in Conversations

Discussion in 'Resolved Bug Reports' started by Marcus, Aug 27, 2013.

  1. Marcus

    Marcus Well-Known Member

    If a user you conversated with is deleted, not "Username" or "Deleted User" is displayed in /conversations [the list of conversations], instead there is just a ", ".

    Last edited: Aug 27, 2013
  2. Chris D

    Chris D XenForo Developer Staff Member

    I can't reproduce this on a conversation just created and a user I subsequently deleted.

    I notice the date: Was this user deleted before an import, or similar?
  3. Marcus

    Marcus Well-Known Member

    It's here on xenforo.com/community

    I conversated with a user who was deleted later. In the conversation list, I see ", ,". The conversation displays him correctly with not-linkeable username.
  4. Marcus

    Marcus Well-Known Member

  5. Marcus

    Marcus Well-Known Member

    I see in lots of my conversations on my community I don't see a list of participated users in conversation_list
  6. Mike

    Mike XenForo Developer Staff Member

    I had actually already fixed this - it was a bug in the earlier betas with the conversation rebuild (which needs to be run to add the recipient list to old conversations). We just hadn't done the rebuild since the fix.

    I have, however, tweaked this code again. Previously, it just hid the fact that there was a deleted member in the conversation. It will now list "unknown member" as that's really all we know (similar to the list in the conversation).
    Marcus and Chris D like this.
  7. Marcus

    Marcus Well-Known Member

    Actually in the conversation view, I do see the users username. So I can identify the user by the username. Now I see in conversation_list "unknown member" and in conversation_view "the_former_username".

Share This Page