• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Now-deleted Guestuser not displayed in Conversations

Marcus

Well-known member
#1
If a user you conversated with is deleted, not "Username" or "Deleted User" is displayed in /conversations [the list of conversations], instead there is just a ", ".

Marcus, , Aug 10, 2010
 
Last edited:

Chris D

XenForo developer
Staff member
#2
I can't reproduce this on a conversation just created and a user I subsequently deleted.

I notice the date: Was this user deleted before an import, or similar?
 

Marcus

Well-known member
#3
It's here on xenforo.com/community

I conversated with a user who was deleted later. In the conversation list, I see ", ,". The conversation displays him correctly with not-linkeable username.
 

Mike

XenForo developer
Staff member
#6
I had actually already fixed this - it was a bug in the earlier betas with the conversation rebuild (which needs to be run to add the recipient list to old conversations). We just hadn't done the rebuild since the fix.

I have, however, tweaked this code again. Previously, it just hid the fact that there was a deleted member in the conversation. It will now list "unknown member" as that's really all we know (similar to the list in the conversation).
 

Marcus

Well-known member
#7
Actually in the conversation view, I do see the users username. So I can identify the user by the username. Now I see in conversation_list "unknown member" and in conversation_view "the_former_username".