• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

No one can reply to threads, having permissions issues

cmeinck

Well-known member
#1
Yesterday, I attempted to set up a forum with a custom feed. The forum was supposed to be setup so that Administrators could post topics and Registered users could reply. I never could get this to work and now I've really bungled things. I have a forum where registered users cannot reply to any thread on any forum, nor can they post a new topic.

What's a quick fix so I can get my forums operational and then move from there.
 

Brogan

XenForo moderator
Staff member
#2
Have you set any permissions to Deny on any usergroups?

Check which usergroups registered members are in, both primary and secondary, and remove and Deny settings.
 

cmeinck

Well-known member
#3
Okay, in Users > Users Group Permissions, I've set Like posts, Post New Thread, Post replies to Allow. This restored posting in most of my forums, except for the new forum where I wanted to restrict to replies.

Screen shot 2011-01-18 at 10.03.28 AM.png

I went to Node Permissions for the forum where I'd like to allow replies. When I set that to Allow, nothing happens.
 

Brogan

XenForo moderator
Staff member
#4
To change the permissions of a particular node to replies only, just revoke the "Post new thread" permission for the usergroups concerned.
 

Brogan

XenForo moderator
Staff member
#6
If you use Deny, even if you set it to Allow on another secondary usergroup they won't be able to post in that node if they get promoted in the future, for example.
Deny should be used very sparingly.

I would suggest using Revoke.
 

dieketzer

Well-known member
#7
bear in mind there are two places you can set post/reply perms.
one is the usergroup permissions and the other is in the node permissions.
 

cmeinck

Well-known member
#8
Everything is working properly. Thank you all for the quick and informative response.

Lesson learned here is to tread lightly when working with permissions.