1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No one can reply to threads, having permissions issues

Discussion in 'Troubleshooting and Problems' started by cmeinck, Jan 18, 2011.

  1. cmeinck

    cmeinck Well-Known Member

    Yesterday, I attempted to set up a forum with a custom feed. The forum was supposed to be setup so that Administrators could post topics and Registered users could reply. I never could get this to work and now I've really bungled things. I have a forum where registered users cannot reply to any thread on any forum, nor can they post a new topic.

    What's a quick fix so I can get my forums operational and then move from there.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Have you set any permissions to Deny on any usergroups?

    Check which usergroups registered members are in, both primary and secondary, and remove and Deny settings.
     
  3. cmeinck

    cmeinck Well-Known Member

    Okay, in Users > Users Group Permissions, I've set Like posts, Post New Thread, Post replies to Allow. This restored posting in most of my forums, except for the new forum where I wanted to restrict to replies.

    Screen shot 2011-01-18 at 10.03.28 AM.png

    I went to Node Permissions for the forum where I'd like to allow replies. When I set that to Allow, nothing happens.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    To change the permissions of a particular node to replies only, just revoke the "Post new thread" permission for the usergroups concerned.
     
  5. cmeinck

    cmeinck Well-Known Member

    Revoke meaning "Deny". Just want to be sure.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    If you use Deny, even if you set it to Allow on another secondary usergroup they won't be able to post in that node if they get promoted in the future, for example.
    Deny should be used very sparingly.

    I would suggest using Revoke.
     
  7. dieketzer

    dieketzer Well-Known Member

    bear in mind there are two places you can set post/reply perms.
    one is the usergroup permissions and the other is in the node permissions.
     
  8. cmeinck

    cmeinck Well-Known Member

    Everything is working properly. Thank you all for the quick and informative response.

    Lesson learned here is to tread lightly when working with permissions.
     

Share This Page