1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Copied DB, copied site to subdomain: no one can login, what have I missed?

Discussion in 'XenForo Questions and Support' started by slewis1972, May 15, 2015.

  1. slewis1972

    slewis1972 Member

    As per previous post, I am moving my site from a root folder to a subdomain.

    While I get my htaccess file sorted, I thought, copy database and start to test - that went all ok

    But no one can login. Keep getting password incorrect. Tried main super admins, and not normal users passwords that I know. Proved it by going back to main site and they worked all ok there.

    Checked FAQ, not seen this, so not sure if related to my htaccess file or something else.
    Everything works if I move it to a subfolder of my root, just not to a subdomain.

    Any ideas?
  2. Mike

    Mike XenForo Developer Staff Member

    This can happen if your site has been downgraded to PHP 5.2. PHP 5.2 doesn't support the more secure password system we use for PHP 5.3 upwards. Given that PHP 5.2 is no longer supported (nor is PHP 5.3), I would strongly recommend contacting your host regarding the PHP version in use.
  3. slewis1972

    slewis1972 Member

    Not aware of this, and moved dbs before all ok, just not to subdomian. Even have the test one on same mysql server. PHP is 5.2.6
  4. Mike

    Mike XenForo Developer Staff Member

    PHP 5.2.6 doesn't actually meet XenForo's own basic requirements (which are currently 5.2.11). It sounds like you may have the ability to choose the PHP version in use. Your host should be able to provide guidance though.
  5. slewis1972

    slewis1972 Member

    ok, just worked this out and gone to 5.6. Same issue.
  6. Mike

    Mike XenForo Developer Staff Member

    In the root XenForo directory, create a file called info.php with this in it:
    <?php phpinfo();
    When you access it, what PHP version does it show?

Share This Page