• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

No Increase in User Post Count 2.1.0

No permission to download

Liam W

Well-known member
#1
Liam W submitted a new resource:

No Increase in User Post Count - An updated and fixed version...

This is an update for @Chris Deeming's resource here.

Chris no longer has much time to keep it updated, and the addon had a severe bug in it, so I've fixed the bug (as requested by a member here). Chris has given me permission to re-release the updated version.

It has the same function, however it uses a completely different system and doesn't use queries anymore.

It should work on all...
Read more about this resource...
 

Gazhyde

Well-known member
#2
Does this apply retrospectively, or start from the point of install? Tempted to install it, but if its retrospective our top poster will probably become our lowest poster over night :p
 

Liam W

Well-known member
#4
Liam W updated No Increase in User Post Count with a new update entry:

Added permission, added option to include threads, added rebuilder (1.2+).

  • Added permission
    You can now choose which users/usergroups will be exempt from this addon. This can be done globally, or on a per-node basis.
  • Option to include threads
    In the older versions, threads may not have been included in this addons task. You can now choose if they are, or not.
  • Added rebuilder (1.2+)
    If you're running xF 1.2 or above, you will notice a new entry in the cache rebuilders menu. Running this will re-calculate all the post counts for every user, based on this...
Read the rest of this update entry...
 

mistypants

Well-known member
#6
My users are reporting this error when they try to post in my selected nodes:



Disabling the add-on makes the error go away. Thanks. :)
Just tested this again in 1.2.4 and I'm still getting the issue. Here's the full error:
Code:
Error Info
ErrorException: Illegal offset type in isset or empty - library/XenForo/Visitor.php:230
Generated By: Misty, A moment ago
Stack Trace

#0 /xxx/public_html/library/XenForo/Visitor.php(230): XenForo_Application::handlePhpError(2, 'Illegal offset ...', '/home/khvids/pu...', 230, Array)
#1 /xxx/public_html/library/XenForo/Visitor.php(217): XenForo_Visitor->getNodePermissions(Array)
#2 /xxx/public_html/library/NoPostCountIncrease/DataWriter/DiscussionMessage/Post.php(18): XenForo_Visitor->hasNodePermission(Array, 'noIncreaseExemp...')
#3 /xxx/public_html/library/XenForo/DataWriter/DiscussionMessage.php(557): NoPostCountIncrease_DataWriter_DiscussionMessage_Post->_updateUserMessageCount()
#4 /xxx/public_html/library/XenForo/DataWriter.php(1397): XenForo_DataWriter_DiscussionMessage->_postSave()
#5 /xxx/public_html/library/XenForo/ControllerPublic/Thread.php(548): XenForo_DataWriter->save()
#6 /xxx/public_html/library/DoublePost/ControllerPublic/Thread.php(40): XenForo_ControllerPublic_Thread->actionAddReply()
#7 /xxx/public_html/library/XenForo/FrontController.php(347): DoublePost_ControllerPublic_Thread->actionAddReply()
#8 /xxx/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#9 /xxx/public_html/index.php(13): XenForo_FrontController->run()
#10 {main}

Request State

array(3) {
  ["url"] => string(59) "http://kh-vids.net/threads/rp-section-news.112712/add-reply"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(10) {
    ["message_html"] => string(65) "<p>testing plz ignore me<br></p>"
    ["_xfRelativeResolver"] => string(50) "http://kh-vids.net/threads/rp-section-news.112712/"
    ["macros"] => string(1) "-"
    ["attachment_hash"] => string(32) "93e389e14e6f8dbed74c0a04822a111e"
    ["last_date"] => string(10) "1387604735"
    ["last_known_date"] => string(10) "1387604735"
    ["_xfToken"] => string(8) "********"
    ["_xfRequestUri"] => string(32) "/threads/rp-section-news.112712/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}
 
#12
Is the rewrite ready to go or not? Because I am looking for something like this for my forum. Where I have got an auto bot account and I don't want the post count to increase for it within selected forums.
 

Liam W

Well-known member
#13
Is the rewrite ready to go or not? Because I am looking for something like this for my forum. Where I have got an auto bot account and I don't want the post count to increase for it within selected forums.
Possibly, but I completely forgot about this. I have so much to do, certain things slip my mind if I'm not reminded. I'll check my addon files.

Liam
 

RAHSTYLES

Active member
#15
The following error occurred:
Illegal offset type in isset or empty
  1. XenForo_Application::handlePhpError() in XenForo/Visitor.php at line 230
  2. XenForo_Visitor->getNodePermissions() in XenForo/Visitor.php at line 217
  3. XenForo_Visitor->hasNodePermission() in NoPostCountIncrease/DataWriter/DiscussionMessage/Post.php at line 18
  4. NoPostCountIncrease_DataWriter_DiscussionMessage_Post->_updateUserMessageCount() inXenForo/DataWriter/DiscussionMessage.php at line 559
  5. XenForo_DataWriter_DiscussionMessage->_postSave() in XenForo/DataWriter.php at line 1423
  6. XenForo_DataWriter->save() in XenForo/ControllerPublic/Thread.php at line 578
  7. XenForo_ControllerPublic_Thread->actionAddReply() in Siropu/NewUserPostRestrictions/ControllerPublic/Thread.php at line19
  8. Siropu_NewUserPostRestrictions_ControllerPublic_Thread->actionAddReply() in EWRporta2/ControllerPublic/Thread.php at line 35
  9. EWRporta2_ControllerPublic_Thread->actionAddReply() in XenForo/FrontController.php at line 351
  10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  11. XenForo_FrontController->run() in /home/whatsgoo/public_html/test/index.php at line 13
 

vkams

Active member
#17
I've got an error at hosting and at home server too:
XenForo_Exception: Requested user not found. - library\XenForo\DataWriter.php:1359
Generated By: Unknown Account, 2 minutes ago
Stack Trace
#0 C:\OpenServer\domains\fai\library\XenForo\DataWriter.php(1401): XenForo_DataWriter->_haveErrorsPreventSave()
#1 C:\OpenServer\domains\fai\library\LiamW\NoPostCountIncrease\Deferred\Rebuild.php(168): XenForo_DataWriter->save()
#2 C:\OpenServer\domains\fai\library\XenForo\Model\Deferred.php(295): LiamW_NoPostCountIncrease_Deferred_Rebuild->execute(Array, Array, 7.8389911651611, '')
#3 C:\OpenServer\domains\fai\library\XenForo\Model\Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.8389911651611, '', false)
#4 C:\OpenServer\domains\fai\library\XenForo\Model\Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 7.8389911651611, '', false)
#5 C:\OpenServer\domains\fai\library\XenForo\ViewRenderer\Abstract.php(352): XenForo_Model_Deferred->run(true, 7.8389911651611)
#6 C:\OpenServer\domains\fai\library\XenForo\ViewRenderer\Json.php(147): XenForo_ViewRenderer_Abstract::hasManualDeferredToRun()
#7 C:\OpenServer\domains\fai\library\XenForo\ViewRenderer\Json.php(185): XenForo_ViewRenderer_Json::_addDefaultParams(Array)
#8 C:\OpenServer\domains\fai\library\XenForo\ViewRenderer\Json.php(104): XenForo_ViewRenderer_Json::jsonEncodeForOutput(Array)
#9 C:\OpenServer\domains\fai\library\XenForo\FrontController.php(607): XenForo_ViewRenderer_Json->renderView('XenForo_ViewAdm...', Array, 'tools_run_defer...', NULL)
#10 C:\OpenServer\domains\fai\library\XenForo\FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_Json), Array)
#11 C:\OpenServer\domains\fai\admin.php(13): XenForo_FrontController->run()
#12 {main}
Request State
array(3) {
["url"] => string(39) "http://fai/admin.php?tools/run-deferred"
["_GET"] => array(1) {
["tools/run-deferred"] => string(0) ""
}
["_POST"] => array(5) {
["execute"] => string(1) "1"
["_xfRequestUri"] => string(24) "/admin.php?tools/rebuild"
["_xfNoRedirect"] => string(1) "1"
["_xfToken"] => string(8) "********"
["_xfResponseType"] => string(4) "json"
}
}
:eek: