1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 New Users Unable to Register - 404 error

Discussion in 'Troubleshooting and Problems' started by stormchaser, Nov 5, 2013.

  1. stormchaser

    stormchaser New Member

    Still testing my site, and currently testing user signup - as a public user.

    From within a new browser, I attempt to create a new user.

    Instead of signing them up, it goes to an "ERROR 404 - PAGE NOT FOUND"

    The board is "active"
    Enable User Registrations is selected
    The installation is in the root directory.

    I do not have any addons or anything installed. Purely just the default installation, which was all successful. I have been creating new Nodes and just all that sort of thing.

    Am I missing something really basic here?
  2. Chris D

    Chris D XenForo Developer Staff Member

    Yes, probably.

    It's likely you have a mistake in your Board URL.
  3. stormchaser

    stormchaser New Member

    Thanks Chris,

    That makes sense. I have just seen it is also serving the 404 error for all other areas of the site too.

    Looking at the Basic Board Info, I am unable to see any mistakes in the URL.

    I have just unticked the Use Friendly URL setting option and refreshed the public board, and it appears nothing is serving the 404 error now.

    My error appears to be because of the Use Friendly URL setting. I will work that out now.

    Hopefully this helps anyone in future with this error.
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    Do you have the necessary server components installed? Are you on apache?
  5. stormchaser

    stormchaser New Member

    Hi Jeremy,

    Yes I can see within my cpanel that it uses Apache.

    I am currently working through this guide - http://xenforo.com/help/friendly-urls/

    But am stuck on renaming the htaccess.txt to .htaccess - Won't allow me to rename within FTP File Manager OR on my PC.
    So I'm currently on Google trying to find how to do that.
  6. stormchaser

    stormchaser New Member


    I was unable to change the htaccess name because in cPanel I was using "File Manager" instead of "Legacy File Manager"

    I then renamed htaccess.txt to .htaccess (http://xenforo.com/help/friendly-urls/) and reticked Use Friendly URL.

    I can confirm that it is all now working correctly. Hopefully it stays that way.

    Hopefully this helps someone else in future too.
    Thankyou to Chris and Jeremy for your replies.
    Adam Howard likes this.

Share This Page