• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 [NEW INSTALLATION] Only homepage is working!

#1
I have an error, I just installed XenForo, All I have done was installed a theme (FlatAwesome by PixelEdit) and one addon (SliderCaptcha), I'm pretty sure I installed it right but the only page that is working is the main page. Everything else gives me an error :

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@spigotplugins.com to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.



Helpful Link
Main page: http://www.spigotplugins.com/
Example of page not working: http://spigotplugins.com/forums/main-forum.2/ http://spigotplugins.com/members/
 

Steve F

Well-known member
#2
You need to look at the server error log, ne should be present in your public_html folder. Aside from that do you have a .htaccess file where you have XF installed?
 

MattW

Well-known member
#3
Do you have the correct details in your .htaccess for Friendly URLs to be enabled, and does the hosting server support mod_rewrite?
 
#4
You need to look at the server error log, ne should be present in your public_html folder. Aside from that do you have a .htaccess file where you have XF installed?
Do you have the correct details in your .htaccess for Friendly URLs to be enabled, and does the hosting server support mod_rewrite?
Just tried disabling friendly-urls and that is the problem, how can i fix this, I have a file called htaccess.txt which includes http://paste.md-5.net/vecuraqupe.apache, i am going to try renaming it to .htacess, i dont know if my host supports mod_rewrite but i dont know why they wouldnt.
 
#5
You need to look at the server error log, ne should be present in your public_html folder. Aside from that do you have a .htaccess file where you have XF installed?
Do you have the correct details in your .htaccess for Friendly URLs to be enabled, and does the hosting server support mod_rewrite?
Just tried disabling friendly-urls and that is the problem, how can i fix this, I have a file called htaccess.txt which includes http://paste.md-5.net/vecuraqupe.apache, i am going to try renaming it to .htacess, i dont know if my host supports mod_rewrite but i dont know why they wouldnt.
Renaming htaccess.txt to .htaccess fixed the problem, i dont know why it did that because i didnt set it to that
 

Tracy Perry

Well-known member
#6
The shipping default is called htaccess.txt... not all HTTP servers use .htaccess (nginx for one does not) and not all admins want to use FURL's.
So you have to rename the htaccess.txt to .htaccess to get it to work. ;)