1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

new installation

Discussion in 'Installation, Upgrade, and Import Support' started by raultice, Oct 19, 2012.

  1. raultice

    raultice New Member

    hi guys i'm hoping you can help me out here.....
    Im trying to install xenforo but everytime i try i keep getting an error. This is what is happening....

    I upload the software,
    change the relivent folder permissions etc.,
    then goto the www.domainname.com/install which works fine,
    input the mySQL details etc.,
    then it says details veryfied etc. begin installation,
    I click the install button but this is where i come to a stop. Once i click it, i get about 30 secs then the page turns to this:

    Internal Server Error


    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.


    Apache/2.2.15 (CentOS) Server at www.ucheat.net Port 80

    Ok so i had a look at the error.log on my server which had this in it for today:

    [Fri Oct 19 02:55:33 2012] [error] [client 64.56.64.136] File does not exist: /var/www/vip16/sites/vip8555822/httpd/htdocs/robots.txt
    [Fri Oct 19 07:24:43 2012] [error] [client 80.40.134.120] File does not exist: /var/www/vip16/sites/vip8555822/httpd/htdocs/robots.txt, referer: http://www.ucheat.net/robots.txt
    [Fri Oct 19 07:24:59 2012] [warn] [client 92.14.255.173] mod_fcgid: read data timeout in 40 seconds, referer: http://www.ucheat.net/install/index.php?install/step/1b
    [Fri Oct 19 07:24:59 2012] [error] [client 92.14.255.173] Premature end of script headers: index.php, referer: http://www.ucheat.net/install/index.php?install/step/1b
    Any chance this means anything to anyone?
    I have tryed this install multiple time but always the same result.
    I did actually have xenforo installed and working with my host provider last year before i canclled my hosting, but this time round i guess something has changed.

    Anyway any help you guys could offer would be appriciated
    many thanks

    Mark
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    http://xenforo.com/community/threads/internal-server-error-on-install.9490/

    This is all I can find...

    Someone had a similar issue. It may be worth getting your host involved as it could be some sort of server issue.

    Overall though, in their case it just started working... but if you've already tried it several times then contacting your host might help shed some light.
     
  3. raultice

    raultice New Member

    ok thanks for the reply Chris - I will contact my host. Is there anything in perticular i need to tell them? Sorry this is all new to me :)

    Also as a side note, i just noticed each time i try the installation in my database I get a different amount of tables created (103 - 139 - 132 etc.) which i gather is not ment to happen?
     
  4. Chris D

    Chris D XenForo Developer Staff Member

  5. raultice

    raultice New Member

    Great, thanks again
     
    Chris D likes this.
  6. Chris D

    Chris D XenForo Developer Staff Member

    Keep us updated on what your host says and how you get on resolving this. Good luck!
     
  7. raultice

    raultice New Member

    ok so i just got this reply from my host:

    Dear Mark,

    The error logs for your web space can be seen from the 'error.log' file, found in the root directory of the webspace. This file confirms that the software is attempting to access files and folders that do not exist, and have incomplete 'index.php' pages.

    Based on this, it seems to me that the software itself, or the configuration of it, is the cause of the issue.

    Well that dosent mean much to me. Maybe an issue with my upload of the software? - just grasping at straws
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    The files that do not exist are robots.txt files which are probably just being accessed by search engine bots. The fact that they aren't there isn't a problem.

    I would say your straw grasping might actually be worth looking into. But do it in the following order:

    1) Delete the files from your PC.
    2) Download the XenForo (full package, not upgrade) to your PC.
    3) Delete all of the XenForo files from your server.
    4) Extract the XenForo package to your PC.
    5) Upload the contents of the upload folder to the desired location on your server.

    Re-run the install.

    I'm sure that's the process you've already followed, but my suspicion at this point is either the download was corrupted, the extraction was corrupted or the upload was corrupted.
     
  9. Digital Doctor

    Digital Doctor Well-Known Member

    This sounds like missing / corrupted files on the server.
    Use Chris' method above. Should work.
     
  10. raultice

    raultice New Member

    :cry: well.... just redid everything from scrach but alas im still getting the exact same problem.
    assuming the problem is corrupted files then i guess somewhere between me downloading the software and then uploading it to the server i am somehow corrupting them...

    would trying the process from a different pc/laptop be worth trying or is that a pointless exercise?
     
  11. Chris D

    Chris D XenForo Developer Staff Member

    It would be worth trying from a different PC, or maybe, try:

    1) Downloading with a different browser (so it's not downloaded from a cache)
    2) Unzipping with a different tool. My personal favourite is 7zip.
    3) Maybe a different FTP Client. My favourite is FileZilla.

    If all that checks out ok, maybe go back to your host. Perhaps you could give them access to your XenForo license so they can download it and upload it for you.

    If then it still doesn't work, at least they can see it's nothing you've done.

    Oh, and they mentioned earlier a bad software configuration. There isn't one. The installer doesn't have any configuration or settings that you can affect so at that point if it still isn't working, I still sniff a server issue.
     
  12. Digital Doctor

    Digital Doctor Well-Known Member

    What FTP program are you using ?
    What are you using to extract it ?
    Did you do a File Health Check in the AdminCP ?
     
  13. raultice

    raultice New Member

    Cute FTP
    WinZip
    As for the Health Check - sorry that means nothing to me :(
     
  14. Digital Doctor

    Digital Doctor Well-Known Member

     
  15. Chris D

    Chris D XenForo Developer Staff Member

    He can't do a File Health Check... it's not installed yet...

    Yeah follow my advice in my previous post. Those apps are usually fine, but we all know what software is like ;)
     
  16. Digital Doctor

    Digital Doctor Well-Known Member

    Oh yea.
     
  17. Digital Doctor

    Digital Doctor Well-Known Member

    This google gave this:

    http://rickchristie.com/blog/2011/note/apache-mod_fcgid-read-data-timeout-error/

    The problem seems to reside within the mod_fcgid. Apparently it’s a FastCGI module for apache2. FastCGI is a protocol for interfacing interactive programs with a web server. FastCGI calls PHP, which then executes the said script. Since the FastCGI application haven’t generated a response within the default IO timeout (40 seconds) – it spits out 500 Internal Server Error.

    I wonder if FastCGI has given people problems in the past ?
    Looks like there can be issues.
     
  18. Chris D

    Chris D XenForo Developer Staff Member

    Yeah definitely could be.

    That kind of thing I assume the host would look into, but probably not until Mark jumps through hoops and confirms it's not a dodgy file or configuration.
     
  19. Digital Doctor

    Digital Doctor Well-Known Member

    Can't there be some MD5 checking app for Xenforo files ?
    or something like that ?
    Some script that runs through all the files and folders and checks for permissions and corrupted uploads ?
     
  20. Chris D

    Chris D XenForo Developer Staff Member

    Yeah that would be pretty good. It does check for permissions IIRC.

    I still think it's server related though but at least a consistency checker built in would have been easier in this case.
     

Share This Page