1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 New help page issue

Discussion in 'Troubleshooting and Problems' started by Zynektic, Jun 15, 2015.

  1. Zynektic

    Zynektic Well-Known Member

    Hi there,

    So I was watching the videos here which seemed pretty easy and created my own help page but when clicking on it I am taken to the main forum URL domain.com rather than domain.com/help/terms I have attached a screenshot of how it was set up which is the same as the video explains. I noticed the URL goes to domain.com/help/terms/ rather than domain.com/help/terms like the other URLs if that makes any difference.

    I am using CTA Featured Threads as a home page so my forum goes to /forums but the domain for help pages is domain.com/help/ so that should not be an issue.

    Any ideas?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I just tested this and it worked fine.

    upload_2015-6-15_22-50-19.png

    upload_2015-6-15_22-51-16.png
     
  3. Zynektic

    Zynektic Well-Known Member

    Well as per my attachment, I have the same thing set up so not sure what the issue is. My add-ons adding help pages direct to the right place but when I add one it just goes to the domain.com URL. I have SSL if that makes any difference or not?
     
  4. Mike

    Mike XenForo Developer Staff Member

    I'm not seeing an attachment...
     
  5. Zynektic

    Zynektic Well-Known Member

    Sorry, added now.

    In the URL part I have 'terms' only but for some reason it is adding a / at the end which seems to be causing my redirection to kick in and take it to domain.com. There is no / in the URL portion so not sure why it is adding this in.
     

    Attached Files:

  6. Brogan

    Brogan XenForo Moderator Staff Member

    I just tested it using the same URL and it's a conflict with my add-on.

    I'll look into it for the next release.
     
    Zynektic likes this.
  7. Zynektic

    Zynektic Well-Known Member

    OK, thanks Brogan.

    I'll make it as a page and use a callback for now.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    To be honest, without looking into it, I have no idea why that would happen as I don't touch the /help route.
     
  9. Zynektic

    Zynektic Well-Known Member

    I'll just make a thread for now with them, was just adding it there so they can find it on the help page, no worries.
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    This could be classed as an XF bug (but I doubt it) as if the option is set to 'No terms and rules', the code loads the index page:
    PHP:
        public function actionTerms()
        {
            
    $options XenForo_Application::get('options');

            if (!
    $options->tosUrl['type'])
            {
                return 
    $this->responseRedirect(
                    
    XenForo_ControllerResponse_Redirect::RESOURCE_CANONICAL_PERMANENT,
                    
    XenForo_Link::buildPublicLink('index')
                );
            }
            else if (
    $options->tosUrl['type'] == 'custom')
            {
                return 
    $this->responseRedirect(
                    
    XenForo_ControllerResponse_Redirect::RESOURCE_CANONICAL_PERMANENT,
                    
    $options->tosUrl['custom']
                );
            }

            return 
    $this->_getWrapper('terms',
                
    $this->responseView('XenForo_ViewPublic_Help_Terms''help_terms')
            );
        }
    So even if you have a custom help page with a route of 'terms', it will always load the index page, in this case the FT page.

    Change the index page route back to forums/and the same will happen with the forum index.

    Although it really makes no sense disabling the default route only to set another identical one.
    Why are you attempting to do it?
     
  11. Zynektic

    Zynektic Well-Known Member

    Well I am half asleep so never tried another URL Portion but since I can use something else and it works then that is fine for now but glad that was found, thanks for checking.
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    It's still not clear why you are trying to use 'terms' which is a default route.

    If you want to keep the same URL but have different content, change the phrase text.
     
  13. Zynektic

    Zynektic Well-Known Member

    I was just making a test page for now, I have my terms page turned off so it did not show and did not realise it was a default route.
     

Share This Page