1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MyseMysterious moderation interference

Discussion in 'XenForo Questions and Support' started by Morgain, Dec 9, 2011.

  1. Morgain

    Morgain Well-Known Member

    Oddity onn a forum only for admins and a usergroup I created called coderguest for coders who help me.

    This coderguest has posted a Reply to the forum
    the forum permissions show coderguest is GREEN on permission to post or reply
    yet their reply shows this moderation message.
    This message is awaiting moderator approval, and is invisible to normal visitors.

    But I haven't set any moderation on this user or this forum.
    Nor can I find any moderation controls where i can release the message.
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Two things to check:

    Admin CP -> Applications -> Display Node Tree -> [click the forum] -> Moderate all messages posted in this forum

    Admin CP -> Users -> List User Groups -> [click the group] -> Follow message moderation rules
  3. Morgain

    Morgain Well-Known Member

    That one I think. I set it to grey.
    Should it be green or red?
    (Sinus headache not very bright bunny today)
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Set it to Allow if you don't want to pre-moderate members of that group.
    Morgain likes this.
  5. Morgain

    Morgain Well-Known Member

    Brogan thank you for your patience. Have done that.

    I still cannot find where to remove the moderation on that post. Have looked in several areas of admincp and also checked the controls around the frontend post.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    You can do it inline, or via the Mod Queue link at the top left.

    If you can't see those then you don't have the relevant moderator permissions.
  7. Morgain

    Morgain Well-Known Member

    admincp/ users/ moderators
    shows me as a Super Moderator

    but no I don't see those controls.
  8. Brogan

    Brogan XenForo Moderator Staff Member

    You need to check the moderator permissions assigned to you.
    These are either assigned via user group or directly to the user.

    Click on your name in the moderator list to check.
  9. Morgain

    Morgain Well-Known Member

    Thank you
    on that Edit page it's all ticked except the top block "Add Moderator to User Groups:"
    that one has Moderator ticked

    I don't understand that part. Why would I add myself as a Moderator to a usergroup? Surely being a Moderator is global?
    If I have to add myself separately to usergroups I have to check all admins and mods every time I create a usergroup. Ugh.
  10. Brogan

    Brogan XenForo Moderator Staff Member

    It's far quicker and easier to assign common moderator permissions to a user group and add moderators to it, than it is to individually apply permissions to every moderator.

    Not all moderators are global, there are also content moderators.
  11. Morgain

    Morgain Well-Known Member

    Oh sorry yes I'm fine with certain moderators to attach to a usergroup or forum.
    But for general purposes for myself as central admin I just want global access.

    I ticked all those boxes for usergroups, now I don't even see that there's a post in that forum to moderate!
    Tried unTicking the Administrator usergroup no difference.

    Where should I see moderation controls appearing when this setting is fixed right?
  12. Brogan

    Brogan XenForo Moderator Staff Member

    You don't need to tick the user group boxes; all you've done is add yourself to every user group.

    Just check the user groups you should be a member of and the moderation controls you require, presumably all.

    The mod tools appear inline in the thread list and thread view and top left on the mod/admin bar.
  13. Morgain

    Morgain Well-Known Member

    Sorry I'm not usually quite THIS thick!

    If I tick only Admins on my EDit Moderator page I can see this pending post on the frontend.l
    If I tick coderguest this user's usergroup I can;t see it.
    Doesn't make sense to me. Why in the first case do I have access to view this pending post but with no control to process it?

    Nothing appears in the thread list, or around the post.
    Can't find anything in admincp.
    My frontend header is not showing admin links etc at the moment.
  14. Brogan

    Brogan XenForo Moderator Staff Member

    Then you have a permissions issue.

    You must be a member of a group which has those permissions set to Never, which will override an Allow.

Share This Page