1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 MyBB to XF - Problem with User Import

Discussion in 'Installation, Upgrade, and Import Support' started by Disciple of Nagash, Oct 26, 2013.

  1. Disciple of Nagash

    Disciple of Nagash Active Member


    I am currently doing some testing with the MyBB importer, and I have discovered a problem with importing users.

    On my MyBB install I am took over from the original owner, hence his user id was 1, mine was 375. Everything was fully changed over including the Super Administrator access.

    When installing XF, when it first asked me to create an admin, I did so with my details.

    However when the import from MyBB was carried out, it changed the admin profile to that of the orginal owner. In the account settings it did keep my avatar and email, but over things such as location and name came from the original owners profile.

    I am assuming it is because the importer is linking the newly created admin profile (being user id 1) to the user id 1 from my old site.

    Is there a way to work around this?

  2. Disciple of Nagash

    Disciple of Nagash Active Member

    Been playing around some more - would I be right in thinking that if I edited XF's config file to $config['superAdmins'] = '375'; before import, that would solve this issue?

    No, just realised can't do that, as 375 doesn't exist yet in XF.....:confused:

    Hmm, think there was an option not to sync user id beforehand......
  3. Mike

    Mike XenForo Developer Staff Member

    If you're maintaining IDs, there's really no way around this - what was user 1 has to stay user 1. If you don't maintain IDs, this doesn't come up.

    As for the super admin stuff, I'm not sure what you're asking there. By the time your import finishes, you should have user 375 and can switch the super admin stuff over.
  4. Disciple of Nagash

    Disciple of Nagash Active Member

    Ok, if I don't maintain IDs, will this affect thread redirection?
  5. Mike

    Mike XenForo Developer Staff Member

    It makes it a little more of a pain. I've mentioned it in the other thread.
  6. Disciple of Nagash

    Disciple of Nagash Active Member

    I've just read through the thread you mentioned, got to admit quite a lot of it flew over my head :oops:

    The details there seem to state however you need to retain the IDs for it to work.

    Can it work without, and is there a "dummy" guide for a MyBB import?

  7. Disciple of Nagash

    Disciple of Nagash Active Member

    Just received the following error when importing:

    Server Error
    Mysqli statement execute error : Duplicate entry '1215' for key 'PRIMARY'
    Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
    Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1612
    XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1601
    XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1393
    XenForo_DataWriter->save() in XenForo/Model/Import.php at line 1888
    XenForo_Model_Import->importAttachment() in XenForo/Model/Import.php at line 1934
    XenForo_Model_Import->importPostAttachment() in XenForo/Importer/MyBb.php at line 1884
    XenForo_Importer_MyBb->stepAttachments() in XenForo/Importer/Abstract.php at line 77
    XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 195
    XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 143
    XenForo_ControllerAdmin_Import->actionImport() in XenForo/FrontController.php at line 337
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/demovamp/public_html/admin.php at line 13
    No idea what this means?

    There are some server error logs if they would be of any help?
  8. Jeremy

    Jeremy XenForo Moderator Staff Member

    Did you attempt to reimport? This is an indication that it tried to reimport the same item twice while retaining IDs.
  9. Disciple of Nagash

    Disciple of Nagash Active Member

    No, but the system did experience a timeout from the server, so maybe that caused it.

    I am trying a fresh import now, this time without retaining the original IDs.
  10. Disciple of Nagash

    Disciple of Nagash Active Member

    So I got all the way to importing attachments, to about 50%, then got this error:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 16000 bytes) in /home/demovamp/public_html/library/XenForo/Image/Gd.php on line 70

    Clicked back, got this error:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 4000 bytes) in /home/demovamp/public_html/library/XenForo/Image/Gd.php on line 70

    I had to got out and back into the ACP, tried continuing the import but keep on getting the first error?
  11. Mike

    Mike XenForo Developer Staff Member

    Your server appears to prevent memory limit increases and actually runs at half of the normal default. Try adding this to the end of your library/config.php:
    $config['maxImageResizePixelCount'] = 10000000;
    If the error continues, set it to 5000000 instead. If it still errors, try 1000000.

    This will not thumbnail larger images then - larger images take more memory to process. Allowing the memory limit to be the default 128M should resolve it (your host probably needs to change that to be settable).
  12. Disciple of Nagash

    Disciple of Nagash Active Member

    Thanks very much. I have logged a ticket with my host as I assume a VPS should be able to handle that, I am not on shared hosting.

Share This Page