1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My forum is down - Not Found error

Discussion in 'Troubleshooting and Problems' started by Hilmer, Mar 5, 2013.

  1. Hilmer

    Hilmer Active Member

    Hi guys - really hope one of you can help me with this trouble:
    A few days ago everything worked fine, but today I got emails from the users of my site - it is down.

    I can enter the page www.hilmer-koch.dk/forum and I can enter admin area.
    But when I enter a post or anything else I get the following error:

    NOT FOUND
    Apologies, but the page you requested could not be found. Perhaps searching will help.

    The address looks fine (as it use to do):

    http://hilmer-koch.dk/forum/threads/med-sikkerhed-en-ulv-i-det-midtjyske.927/
     
  2. The Forum Heroes

    The Forum Heroes Well-Known Member

    Seems it is trying to switch from /forum to /forum/forums/
     
  3. Hilmer

    Hilmer Active Member

  4. Lisa

    Lisa Well-Known Member

    /* edit

    My bad, misread.
     
  5. borbole

    borbole Well-Known Member

    Do you have a .htaccess file in the root of your forum folder? Do you have the Use Full Friendly URLs option checked or unchecked?
     
  6. Ingenious

    Ingenious Well-Known Member

    Is the page not found error a Wordpress generated one (as you have Worldpress in your root)? If so might also be a conflict with your Wordpress .htaccess file?
     
  7. Hilmer

    Hilmer Active Member

    Azhria Lilu: Are you sure - none of me team members can enter anything but the front page?

    Borbole: Yes it is checked and I do have a .htaccess file. Sunday everything worked fine and it has been working perfect for a year or so.
     
  8. Hilmer

    Hilmer Active Member

    Ingenious - okay that make sense. We are using a WP-theme.
    Just tried to uncheck the Use Full Friendly URLs option.
    Now everything works just perfect.

    Any suggestion on how I can get it to work again with the Use Full Friendly URLs option checked? Otherwise A lot of links will be broken..
     
  9. Ingenious

    Ingenious Well-Known Member

    Yes it is a WordPress 404 error. I note that non-fancy URLs work fine (any link within the forum at the moment), but friendly URLs don't, they generate the WP error. I definitely agree with borbole here, it's likely an htaccess problem caused by rewrite settings somewhere, either with Xenforo or Wordpress. Did you change any WP settings over the weekend that you can remember?

    Edit - cross post with yours Hilmer.
     
  10. Ingenious

    Ingenious Well-Known Member

    Did you make any changes in Wordpress to the permalink settings, or have you published a new blog or page with forum/ or forum/threads as the permalink? (Which might cause it to rewrite anything supposed to be for Xenforo)? Clutching at straws a bit here, sorry, as this is not my area of expertise.
     
  11. Hilmer

    Hilmer Active Member

    We are working on our home page in WP, so maybe that is what cause the problems. I am so glad it is working again. Though I really want the Use Full Friendly URLs option to be turned on again - any suggestion on how I can do it so it will not affect get in conflict with my Word Press install?
     
  12. Ingenious

    Ingenious Well-Known Member

    Right, it's coming back to me now, because when I ran WP an XF together I had a conflict and needed to make a change somewhere (sorry it was a while ago and I have since split the forum and WP into different servers). I had to add something to the Wordpress .htaccess file to exclude certain folders from the rewrite settings, ie. the forum folder. If you Google "wordpress permalinks exclude folder" you will get some guides such as:

    http://kbase.siteserving.com/applic...xclude-folders-from-wordpress-permalinks.html

    Basically the change is a small one, it adds a / to one of the lines. You should then be able to switch the friendly URLs back on and WP will ignore forum/ leaving it to Xenforo to rewrite with its own .htaccess.

    Please wait for other members to respond before you start making changes though, because I am not 100% sure this is your problem. What worries me is that it was all working until the weekend, so why did it suddenly stop working?
     
  13. Hilmer

    Hilmer Active Member

    That is so kind of you to help me here Ingenious - I really appreciate. I will wait as you suggest.
     
  14. Hilmer

    Hilmer Active Member

Share This Page