XF 1.2 Moving from /forums to root

grantus

Active member
I currently have Xenforo installed in /forums but if I want to move everything to the root directory, what would be the simplest way?

Obviously I'll move all the files to the root, but how does that affect Xenforo?
Would I have to backup the database, re-install Xenforo and then import the database?
Or is there an easier way?

Thanks.
 

grantus

Active member
Ah ok, so I just need to move all the files to the root and then specify the new forum URL in the AdminCP?
 

grantus

Active member
I'm in the process of moving everything now but there's a problem. I moved all my Xenforo files to the root directory and then changed the board URL. Now when I go to the forum, I can't get to certain areas of the forum. All my nodes still show /forums/general for example. I restarted my server but still same thing. What could be the problem?
 

grantus

Active member
It seems to be that the friendly URLs is not working. When I disabled it, all is good. Any suggestions? Thanks.
 

grantus

Active member
Ah, that could be it! No, I didn't move it yet because I have a custom one in there. I'll reply when I move it over.
 

Marcel

Active member
I tried it on our test installation. No matter what I tried I just couldn't get it to play nice, so I reinstalled
*easywayout* :D
 

grantus

Active member
Ok I moved Xenforo's htaccess, restarted my server and still the same thing. I can access the threads and posts such as: mysite.com/posts/ but on the main page, all the nodes still link to mysite.com/forums
 

grantus

Active member
Nevermind, I got it! It's because since I moved all my xenforo files to the root folder, I still had my "forums" folder. I removed that and so far everything seems good.
 
Top