XF 2.0 Moved Hosts - No Emoji?

Bit of an odd one this one.

I've moved hosts but emojis on threads are coming up as question marks.

The tables have already been converted so I can't convert them again.

Is there anything I can do?
 

Chris D

XenForo developer
Staff member
Make sure:
PHP:
$config['fullUnicode'] = true;
Is still set in your src/config.php file.

If it is, then unfortunately it was likely caused by some sort of issue during the database back up and restore process.
 

Chris D

XenForo developer
Staff member
Not really certain what would have gone wrong other than it somehow being saved as utf8 rather than utf8mb4 when exporting.

This might not actually affect the table collation or database charset itself, but the file it produced may not have produced valid utf8mb4.
 

Chris D

XenForo developer
Staff member
If mysqldump was used then it might need the --default-character-set=utf8mb4 flag setting.
 
By the looks of it a cpanel export to cpanel import does this.

Tried full site/DB only and both do it.

Phpmyadmin export to PHPmyadmin import is falling over due to the size. Will see if host can sort.
 

Chris D

XenForo developer
Staff member
mysqldump is definitely a more robust tool for the job, but it does need shell access. The aforementioned character set flag with mysqldump is probably what will sort it.
 
Gave up in the end, we've just started using XF 2.0 so i replaced the originals that were showing up as question marks.

Noted in case we move again, thanks.
 
Top